ecj-initial: convert to new staging system
[openembedded.git] / recipes / mono / mono-native_2.6.3.bb
blob03820d3cd37637721a6f1c561640c14839333132
1 require mono.inc
2 DEPENDS = "glib-2.0-native perl-native"
4 PR = "${INC_PR}.0"
6 SRC_URI += ""
8 inherit native
10 do_fix_libtool_name() {
11 # inherit native will make that all native tools that are being
12 # built are prefixed with something like "i686-linux-",
13 # including libtool. Fix up some hardcoded libtool names:
14 for i in "${S}"/runtime/*-wrapper.in; do
15 sed -e "s/libtool/${BUILD_SYS}-libtool/" -i "${i}"
16 done
18 addtask fix_libtool_name after do_patch before do_configure
20 SRC_URI[md5sum] = "b1dc21bac2c7c75814a9f32246eadadd"
21 SRC_URI[sha256sum] = "0ecb82d2007f472f8eebc85c349813515bf642e6ea021890ece40555ad50d947"