linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-ixp4xx_2.6.19.bb
blobede5e86af59effca0fae86b4008fbbd6e3623f00
1 require linux.inc
2 require linux-ixp4xx.inc
4 KERNEL_RELEASE = "2.6.19"
6 PV = "${KERNEL_RELEASE}+svnr${SRCPV}"
7 PR = "r0"
9 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${KERNEL_RELEASE}.tar.bz2 \
10 svn://svn.nslu2-linux.org/svnroot/kernel/trunk/patches;module=${KERNEL_RELEASE};proto=http \
11 file://defconfig-${KERNEL_RELEASE}"
13 S = "${WORKDIR}/linux-${KERNEL_RELEASE}"
15 do_prepatch() {
16 mv ${WORKDIR}/${KERNEL_RELEASE} ${S}/patches && cd ${S} && quilt push -av
17 mv patches patches.ixp4xx
18 mv .pc .pc.old
19 mv ${WORKDIR}/defconfig-${KERNEL_RELEASE} ${WORKDIR}/defconfig
22 addtask prepatch after do_unpack before do_patch
24 SRC_URI[md5sum] = "443c265b57e87eadc0c677c3acc37e20"
25 SRC_URI[sha256sum] = "c2fd6bcd2b7c1b3d37d64e4d1825703792a75474830a3db7d2dc603a8d392d58"