linux-omap 2.6.39: initial add with beagleboard support
[openembedded.git] / recipes / linux / linux-epia_2.6.8.1.bb
blob163bd1ffa248ec17d7bac2e9581daf7b63ecb9d7
1 SECTION = "kernel"
2 DESCRIPTION = "Linux kernel for VIA EPiA"
3 LICENSE = "GPLv2"
4 PR = "r15"
6 SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2;name=kernel \
7 http://www.epiawiki.org/files/epia_kernel/patch-2.6.8.1-epia1.bz2;apply=yes;name=patch1 \
8 http://hem.bredband.net/ekmlar/patch-vt1211-2.6.txt;apply=yes;name=patch2 \
9 file://epia_defconfig"
10 S = "${WORKDIR}/linux-${PV}"
12 COMPATIBLE_HOST = 'i.86.*-linux'
14 inherit kernel
16 ARCH = "i386"
18 # Don't want kernel in rootfs
19 FILES_kernel = ""
20 ALLOW_EMPTY_kernel = "1"
21 PACKAGES += "kernel-image"
22 FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
24 do_configure_prepend() {
25 install -m 0644 ${WORKDIR}/epia_defconfig ${S}/.config