db_5.0.21: Add recipes for target and native packages.
[openembedded.git] / recipes / musicpd / mpd_0.14.2.bb
blobf4ba6e570e89e37357b5260dc986a2213b1e1db5
1 DESCRIPTION = "Music Player Daemon (mpd)"
2 HOMEPAGE = "http://www.musicpd.org"
3 SECTION = "console/multimedia"
4 LICENSE = "GPLv2"
5 DEPENDS = "libvorbis libogg libao zlib libmikmod flac audiofile virtual/libiconv faad2 pulseaudio curl lame \
6 ${@base_conditional('ENTERPRISE_DISTRO', '1', '', 'libmad libid3tag', d)}"
8 SRC_URI = "${SOURCEFORGE_MIRROR}/musicpd/mpd-${PV}.tar.bz2 \
9 file://mpd/mpd.conf \
10 file://mpd/mpd.init"
12 PR = "r5"
14 inherit autotools update-rc.d
15 INITSCRIPT_NAME = "mpd"
17 # Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
18 # be built, instead we use the OE built versions which should be installed
19 # in staging - remove the --with and replace with --enable to use the local
20 # versions.
22 EXTRA_OECONF = "\
23 --enable-ogg \
24 --with-id3tag-libraries=${STAGING_LIBDIR} \
25 --with-id3tag-includes=${STAGING_INCDIR} \
26 --with-mad-libraries=${STAGING_LIBDIR} \
27 --with-mad-includes=${STAGING_INCDIR} \
28 --with-faad-libraries=${STAGING_LIBDIR} \
29 --with-faad-includes=${STAGING_INCDIR} \
30 --disable-curl \
31 --disable-ffmpeg \
32 --disable-jack \
33 --enable-pulse \
34 --enable-mod \
35 --disable-oggflac \
36 --with-lame-includes=${STAGING_INCDIR}"
38 do_compile_prepend() {
39 find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
42 do_install_append() {
43 install -d ${D}${sysconfdir}/init.d
44 install -m 755 ${WORKDIR}/mpd/mpd.init ${D}${sysconfdir}/init.d/mpd
45 install -m 644 ${WORKDIR}/mpd/mpd.conf ${D}${sysconfdir}/mpd.conf
49 SRC_URI[md5sum] = "66817a4b4c05454e6488f6b821f2a6a3"
50 SRC_URI[sha256sum] = "0b3926a141873f179efc3c3b9d296b65d332dbb898340ac5e5d1dd0c3dd9fb20"