db_5.0.21: Add recipes for target and native packages.
[openembedded.git] / recipes / libsigc++-1.2 / libsigc++-1.2_1.2.7.bb
blobc68105b17eb0a1f5701b23517ef61d806b542ef6
1 DESCRIPTION = "A library for loose coupling of C++ method calls"
2 SECTION = "libs"
3 PRIORITY = "optional"
4 LICENSE = "GPL LGPL"
5 PR = "r0"
7 SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libsigc++/1.2/libsigc++-${PV}.tar.bz2 \
8 file://autofoo.patch \
9 file://disable-tests.patch"
10 S = "${WORKDIR}/libsigc++-${PV}"
12 inherit autotools pkgconfig
14 # FIXME: Check why tests don't compile
16 acpaths = ""
18 do_stage() {
19 install -d ${STAGING_LIBDIR}/sigc++-1.2/include
20 install -m 0644 sigc++/config/sigcconfig.h ${STAGING_LIBDIR}/sigc++-1.2/include/
21 oe_libinstall -so -C sigc++ libsigc-1.2 ${STAGING_LIBDIR}
23 install -d ${STAGING_INCDIR}/sigc++-1.2/sigc++
24 for f in sigc++/*.h
26 install -m 0644 $f ${STAGING_INCDIR}/sigc++-1.2/sigc++/
27 done
30 FILES_${PN}-dev += "${libdir}/sigc++-*/"
32 SRC_URI[md5sum] = "212f48536019e1f003d2509b4c9b36df"
33 SRC_URI[sha256sum] = "d9163d90e259bfde9164c7b218475a7664a7907a1b3197f17bc1035f36112225"