db_5.0.21: Add recipes for target and native packages.
[openembedded.git] / recipes / efl1 / edbus_svn.bb
blob087bfe7c97825d6f78e9872818fd3bd716d3a9eb
1 DESCRIPTION = "DBus and HAL convenience wrappers for EFL"
2 DEPENDS = "dbus ecore"
3 LICENSE = "MIT BSD"
4 PV = "0.5.0.060+svnr${SRCPV}"
5 PR = "r1"
6 SRCREV = "${EFL_SRCREV}"
8 inherit efl
10 SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=e_dbus;proto=http"
11 S = "${WORKDIR}/e_dbus"
13 EXTRA_OECONF = "--enable-build-test-gui"
15 PACKAGES =+ "${PN}-enotify ${PN}-edbus ${PN}-enm ${PN}-ehal ${PN}-test-gui"
16 FILES_${PN}-enotify = "${libdir}/libenotify.so.*"
17 FILES_${PN}-edbus = "${libdir}/libedbus.so.*"
18 FILES_${PN}-enm = "${libdir}/libenm.so.*"
19 FILES_${PN}-ehal = "${libdir}/libehal.so.*"
20 FILES_${PN}-test-gui = "${bindir}/e_dbus_hal"