uclibc: remove obsolete patches for git version
[openembedded.git] / recipes / junit / junit4_4.3.1.bb
blob587180ba696de9541f78e3d60e7c61965386efa4
1 DESCRIPTION = "JUnit is a testing framework for Java"
2 LICENSES = "CPL"
3 AUTHOR = "junit.org"
4 HOMEPAGE = "http://www.junit.org"
6 SRC_URI = "http://downloads.sourceforge.net/junit/junit-${PV}-src.jar"
8 S = "${WORKDIR}"
10 inherit java-library
12 DEPENDS = "fastjar-native"
14 do_compile() {
15 mkdir -p build
17 # Workaround for jamvm.
18 bcp=${STAGING_DATADIR_NATIVE}/classpath/glibj.zip
20 javac -source 5.0 -bootclasspath $bcp -sourcepath . -d build `find . -name "*.java"`
22 fastjar -C build -c -f ${JARFILENAME} .
25 SRC_URI[md5sum] = "170f9645a41398388e8553b32ff5f630"
26 SRC_URI[sha256sum] = "57d1e49ee3fd0dbdc0a68a852925c973af5c30b1725b6aa63bfb42df6f7c3349"