mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / python / python-setuptools_0.6c9.bb
blob93eb4855dc85ff25fa4c153eb37b48479e81cf22
1 DESCRIPTION = "Download, build, install, upgrade, and uninstall Python packages"
2 HOMEPAGE = "http://cheeseshop.python.org/pypi/setuptools"
3 SECTION = "devel/python"
4 PRIORITY = "optional"
5 LICENSE = "MIT"
6 SRCNAME = "setuptools"
7 PR = "ml2"
8 DEPENDS += "python"
9 DEPENDS_virtclass-native += "python-native"
11 SRC_URI = "\
12 http://cheeseshop.python.org/packages/source/s/setuptools/${SRCNAME}-${PV}.tar.gz\
13 file://fix-log-usage.patch \
15 S = "${WORKDIR}/${SRCNAME}-${PV}"
17 inherit distutils
19 do_install_prepend() {
20 install -d ${D}/${libdir}/${PYTHON_DIR}/site-packages
23 RDEPENDS_${PN} = "\
24 python-distutils \
25 python-compression \
28 SRC_URI[md5sum] = "3864c01d9c719c8924c455714492295e"
29 SRC_URI[sha256sum] = "e6190497301b6cb1484b9e6173723452c8df1b4cd9ea97af75c9589b1c34b3d8"
31 BBCLASSEXTEND = "native"
33 NATIVE_INSTALL_WORKS = "1"