mesa-7.9: bump PR after talloc changes
[openembedded.git] / recipes / python / python-pymp3_0.3.4.bb
blob0d5940db30ccf0fa1a541d59ec12a7f555d8900e
1 DESCRIPTION = "A Curses-based mp3 player. See http://damien.degois.info/PyMP3/"
2 SECTION = "console/multimedia"
3 PRIORITY = "optional"
4 RDEPENDS_${PN} = "python-core python-curses python-pyid3lib python-mad python-ao"
5 LICENSE = "GPL"
6 PR = "r4"
8 SRC_URI = "http://www.vanille.de/mirror/PyMP3-0.3.4.tar.gz"
9 S = "${WORKDIR}/PyMP3-0.3.4"
11 inherit distutils-base
13 PY_FILES = "box_info.py layer.py sound_ctrl.py stack.py txt_tools.py"
15 do_install() {
16 install -d ${D}${libdir}
17 install -d ${D}${libdir}/${PYTHON_DIR}
18 install -d ${D}${libdir}/${PYTHON_DIR}/site-packages
20 for f in ${PY_FILES}
22 install -m 0644 $f ${D}${libdir}/${PYTHON_DIR}/site-packages/
23 done
25 install -d ${D}${bindir}
26 install -m 755 pymp3 ${D}${bindir}/
29 FILES_${PN} += " ${libdir}/${PYTHON_DIR}/site-packages/"
31 SRC_URI[md5sum] = "28e884057750aa4f0da368678e5b20bd"
32 SRC_URI[sha256sum] = "e534ea5505e2d0a571ca8baa4b34260953e796f6c762013756373f13411ebd6e"