u-boot: remove 'inline' from functions with weak attribute.
[openembedded.git] / recipes / u-boot / u-boot_2009.08.bb
blob1ba7c2f27d48c587a5bd710aac3763f494783aad
1 PR = "r2"
2 require u-boot.inc
4 DEFAULT_PREFERENCE = "-1"
5 DEFAULT_PREFERENCE_at91sam9g20ek = "1"
6 DEFAULT_PREFERENCE_at91sam9g45ek = "1"
7 DEFAULT_PREFERENCE_igep0020 = "1"
9 SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
10 SRC_URI += "file://u-boot-2009.08-remove-inline-of-weak-functions.patch;patch=1"
12 SRC_URI_append_igep0020 = " \
13 file://update-mach-types.patch;patch=1 \
14 file://add-board-support-for-IGEP-v2-series-rev-B.patch;patch=1 \
17 TARGET_LDFLAGS = ""
19 inherit base
21 do_compile () {
22 oe_runmake ${UBOOT_MACHINE}
23 oe_runmake all