python-paste: Add new recipe
[openembedded.git] / recipes / python / python-native_2.6.1.bb
blob9b59c1be652229f33478810f53186e1a84a463d5
1 require python.inc
2 DEPENDS = "openssl-native bzip2-full-native zlib-native readline-native"
3 PR = "${INC_PR}.2"
5 SRC_URI = "\
6 http://www.python.org/ftp/python/${PV}/Python-${PV}.tar.bz2 \
7 file://00-fix-bindir-libdir-for-cross.patch;patch=1 \
8 file://04-default-is-optimized.patch;patch=1 \
9 file://05-enable-ctypes-cross-build.patch;patch=1 \
10 file://10-distutils-fix-swig-parameter.patch;patch=1 \
11 file://11-distutils-never-modify-shebang-line.patch;patch=1 \
12 file://12-distutils-prefix-is-inside-staging-area.patch;patch=1 \
13 file://debug.patch;patch=1 \
14 file://nohostlibs.patch;patch=1 \
16 S = "${WORKDIR}/Python-${PV}"
18 inherit native
20 EXTRA_OEMAKE = '\
21 BUILD_SYS="" \
22 HOST_SYS="" \
23 LIBC="" \
24 STAGING_LIBDIR=${STAGING_LIBDIR_NATIVE} \
25 STAGING_INCDIR=${STAGING_INCDIR_NATIVE} \
28 do_stage_append() {
29 install -m 0755 Parser/pgen ${STAGING_BINDIR_NATIVE}/pgen