python-paste: Add new recipe
[openembedded.git] / recipes / nautilus / nautilus_2.28.1.bb
blobe3a551c76f8e4513121ace4f197745c6d8b72257
1 # nautilus OE build file
2 # Copyright (C) 2005, Advanced Micro Devices, Inc. All Rights Reserved
3 # Released under the MIT license (see packages/COPYING)
5 inherit gnome
7 SRC_URI += "file://idl-sysroot.patch;patch=1 \
8 file://no-try-run-strftime.diff;patch=1 \
11 export SYSROOT = "${STAGING_DIR_HOST}"
13 LICENSE="GPL"
15 DEPENDS += "libunique gvfs tracker librsvg libexif eel esound gnome-desktop orbit2-native"
16 RDEPENDS = "gvfs gvfsd-ftp gvfsd-sftp gvfsd-trash"
18 EXTRA_OECONF = " --disable-gtk-doc --disable-update-mimedb "
20 PACKAGES += " libnautilus"
22 FILES_${PN} += "${datadir}/icons /usr/libexec/ "
23 FILES_libnautilus = "/usr/lib/*.so*"
24 FILES_${PN}-dbg += "/usr/libexec/.debug"
26 do_configure_prepend() {
27 sed -i -e /docs/d Makefile.am
30 # We need native orbit-idl with target idl files. No way to say it in a clean way:
31 do_configure_append () {
32 find -name Makefile -exec sed -i '/\/usr\/bin\/orbit-idl-2/{s:/usr/bin:${STAGING_BINDIR_NATIVE}:;s:/usr/share:${STAGING_DATADIR}:g}' {} \;
35 do_stage() {
36 autotools_stage_all