m68k: use _dl_static_init to set GLR0(dl_pagesize)
[glibc.git] / ports / sysdeps / unix / sysv / linux / m68k / Makefile
blobde27824a5754c51766ca59f761fd69c7a7aa64cc
1 # Linux/m68k uses Motorola asm syntax and the ELF format.
3 m68k-syntax-flag = -DMOTOROLA_SYNTAX
5 ifeq ($(subdir),csu)
6 sysdep_routines += m68k-helpers
7 endif
9 ifeq ($(subdir),misc)
10 sysdep_routines += mremap
11 sysdep_headers += sys/reg.h
12 endif
14 ifeq ($(subdir),elf)
15 sysdep-dl-routines += dl-static
16 sysdep_routines += dl-vdso libc-m68k-vdso dl-static
17 sysdep-rtld-routines += m68k-vdso dl-static
18 sysdep-others += lddlibc4
19 install-bin += lddlibc4
20 endif
22 ifeq ($(subdir),resource)
23 sysdep_routines += oldgetrlimit64
24 endif