dev-util/jetbrains-toolbox: add 2.4.2.32922, drop 2.0.3.17006
[gentoo-zh.git] / app-crypt / archlinux-keyring / archlinux-keyring-20231222.ebuild
blob361afaf348a25f8ce6f9909d6f67635f31cffc53
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 DESCRIPTION="GnuPG keyring of Archlinux developer keys"
7 HOMEPAGE="https://gitlab.archlinux.org/archlinux/archlinux-keyring"
8 #SRC_URI="https://sources.archlinux.org/other/${PN}/${P}.tar.gz"
9 SRC_URI="https://gitlab.archlinux.org/archlinux/${PN}/-/archive/${PV}/${P}.tar.bz2"
10 LICENSE="GPL-2" # "GPL" for the Arch linux package
11 SLOT="0"
12 KEYWORDS="~amd64"
13 BDEPEND="app-crypt/sequoia-sq"
15 src_compile(){
16 emake build
19 src_install(){
20 emake PREFIX='/usr' DESTDIR="${D}" install
23 pkg_postinst() {
24 einfo ""
25 einfo "This package only installs the keyring files while sys-apps/pacman"
26 einfo "initializes these keyrings to actually use it. This is a different"
27 einfo "behaviour from Archlinux, but is necessary to avoid circular deps."
28 einfo ""