clean cvs header
[gentoo-zh.git] / app-i18n / lunar / lunar-2.2-r4.ebuild
blobb9eb71a109464c85eb62d0576685cbe04f91b0a9
1 # Copyright 1999-2021 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 inherit eutils toolchain-funcs
6 DESCRIPTION="Chinese Lunar Calendar conversion utility"
7 HOMEPAGE="http://packages.debian.org/unstable/utils/lunar"
8 SRC_URI="mirror://debian/pool/main/l/${PN}/${PN}_${PV}.orig.tar.gz
9 mirror://debian/pool/main/l/${PN}/${PN}_${PVR/r4/3.1}.diff.gz"
11 LICENSE="GPL-2"
12 SLOT="0"
13 KEYWORDS="~x86 ~amd64"
14 IUSE=""
16 S="${WORKDIR}/${PN}"
18 src_unpack() {
19 unpack ${A}
20 cd "${S}"
21 epatch ../"${PN}_${PVR/r4/3.1}".diff
24 src_compile() {
25 $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o ${PN} ${PN}.c || die "compile failed"
28 src_install() {
29 dobin lunar || die "dobin failed"
30 doman lunar.1 || die "doman failed"
31 insinto /usr/share/lunar
32 doins lunar.bitmap || die "doins failed"