app-misc/yq-bin: bump version to 4.40.5
[gentoo-zh.git] / media-sound / yesplaymusic-bin / yesplaymusic-bin-0.4.6.ebuild
blob0e0e2d1d9ca4e7fb8c19a846e354cf7e31c15401
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit desktop xdg
8 DESCRIPTION="A third party music player for Netease Music"
9 HOMEPAGE="https://github.com/qier222/YesPlayMusic"
10 BASE_URI="https://github.com/qier222/YesPlayMusic/releases/download/v${PV}"
11 SRC_URI="${BASE_URI}/${PN%-bin}-${PV}.pacman"
13 LICENSE="MIT"
14 SLOT="0"
15 KEYWORDS="~amd64"
17 RESTRICT="mirror strip"
19 QA_PRESTRIPPED="*"
21 RDEPEND="
22 app-arch/gzip
23 dev-libs/nss
24 media-libs/alsa-lib
25 net-print/cups
26 x11-libs/gtk+:*
27 x11-libs/libxkbcommon"
29 S="${WORKDIR}"
31 QA_PREBUILT="
32 opt/YesPlayMusic/chrome-sandbox
33 opt/YesPlayMusic/libEGL.so
34 opt/YesPlayMusic/libGLESv2.so
35 opt/YesPlayMusic/libffmpeg.so
36 opt/YesPlayMusic/libvk_swiftshader.so
37 opt/YesPlayMusic/libvulkan.so.1
38 opt/YesPlayMusic/swiftshader/libEGL.so
39 opt/YesPlayMusic/swiftshader/libGLESv2.so
40 opt/YesPlayMusic/yesplaymusic
43 src_unpack(){
44 tar xf "${DISTDIR}/yesplaymusic-${PV}.pacman" || die
47 src_install(){
48 insinto "/opt"
49 doins -r "${S}/opt/YesPlayMusic"
50 for si in 16 24 32 48 64 128 256 512; do
51 doicon -s ${si} usr/share/icons/hicolor/${si}x${si}/apps/${PN%-bin}.png
52 done
53 domenu "${FILESDIR}/${PN%-bin}.desktop"
54 fperms 0755 "/opt/YesPlayMusic/yesplaymusic"