dev-util/android-studio: new package, add 2023.2.1.25
[gentoo-zh.git] / x11-wm / hypr / hypr-1.1.3.ebuild
blob4519f6f85c851c16f0494cd050e3c53848e04e29
1 # Copyright 1999-2023 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit cmake toolchain-funcs
8 DESCRIPTION="A dynamic Linux tiling window manager for Xorg"
9 HOMEPAGE="https://github.com/hyprwm/Hypr"
10 SRC_URI="https://github.com/hyprwm/Hypr/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
12 LICENSE="BSD"
13 SLOT="0"
14 KEYWORDS="~amd64"
15 S="${WORKDIR}/Hypr-${PV}"
17 DEPEND="x11-libs/cairo
18 dev-util/ninja
19 x11-libs/libxcb
20 x11-base/xcb-proto
21 x11-libs/xcb-util
22 x11-libs/xcb-util-cursor
23 x11-libs/xcb-util-keysyms
24 x11-libs/xcb-util-wm
25 dev-cpp/gtkmm:3.0
26 gui-libs/gtk"
28 PATCHES=(
29 "${FILESDIR}/fix-build.patch"
32 pkg_pretend() {
33 if ! tc-is-gcc; then
34 ewarn "Only GCC is officially supported as compiler"
35 ewarn "Proceed with your own caution"
39 src_install() {
40 dobin "${BUILD_DIR}/Hypr"
41 dodoc "${S}/example/hypr.conf"