app-misc/yq-bin: bump version to 4.28.2
[gentoo-zh.git] / x11-terms / wezterm-bin / wezterm-bin-20220624.ebuild
blob9a15b9ecc0ea7fab018bd70d5db7521c31b90828
1 # Copyright 1999-2022 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 inherit rpm xdg
8 MY_R="141144-bd1b7c5d"
9 MY_PV="${PV}-${MY_R}"
10 MY_PN="${PN/-bin/}"
11 MY_P="${MY_PN}-${MY_PV}"
13 DESCRIPTION="Bleeding edge builds of a GPU-accelerated cross-platform terminal emulator and multiplexer implemented in Rust"
14 HOMEPAGE="https://wezfurlong.org/wezterm"
16 SRC_URI="https://github.com/wez/wezterm/releases/download/${MY_PV}/${MY_PN}-${PV}_${MY_R/-/_}-1.x86_64.rpm"
18 LICENSE="MIT"
19 SLOT="0"
20 KEYWORDS="~amd64"
22 IUSE="wayland +X"
23 REQUIRED_USE="|| ( wayland X )"
25 RESTRICT="mirror"
27 DEPEND=""
28 RDEPEND="${DEPEND}
29 sys-apps/dbus
30 >=media-libs/fontconfig-2.12
31 >=dev-libs/openssl-1.1
32 wayland? (
33 dev-libs/wayland
34 dev-libs/wayland-protocols
36 X? (
37 >=x11-libs/libX11-1.7.5
38 >=x11-libs/libxcb-1.8
39 >=x11-libs/xcb-util-0.4
40 >=x11-libs/xcb-util-wm-0.4.1
41 >=x11-libs/xcb-util-image-0.2.1
42 >=x11-libs/xcb-util-keysyms-0.4
43 x11-libs/libxkbcommon[X]
45 x11-themes/hicolor-icon-theme
48 S="${WORKDIR}"
50 QA_PREBUILT="*"
52 src_install() {
53 insinto /
54 doins -r etc usr
56 fperms 0755 -R /usr/bin/
57 fperms 0755 -R /etc/profile.d/