app-office/lyx: UNPACK SUCKS, KTHNX
[gentoo-soor-overlay.git] / app-office / lyx / lyx-9999.ebuild
blob7df035428476b26fa75d6b94ffe2c1e113bd1622
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit autotools subversion eutils flag-o-matic font toolchain-funcs
9 FONT_P="latex-xft-fonts-0.1"
11 DESCRIPTION="WYSIWYM frontend for LaTeX, DocBook, etc."
12 HOMEPAGE="http://www.lyx.org/"
13 ESVN_REPO_URI="svn://svn.lyx.org/lyx/lyx-devel/trunk"
14 SRC_URI="ftp://ftp.lyx.org/pub/lyx/contrib/${FONT_P}.tar.gz
15 linguas_he? (
16 http://cs.haifa.ac.il/~dekelts/lyx/files/hebrew.bind
17 http://cs.haifa.ac.il/~dekelts/lyx/files/preferences
20 LICENSE="GPL-2"
21 SLOT="0"
22 KEYWORDS=""
23 IUSE="cups debug nls pch linguas_he latex"
24 RESTRICT="test"
26 RDEPEND="|| (
28 x11-libs/qt-core:4
29 x11-libs/qt-gui:4
31 =x11-libs/qt-4.3*
32 =x11-libs/qt-4.2*
34 x11-libs/libXrandr
35 x11-libs/libXcursor
36 x11-libs/libXrender
37 x11-libs/libXfixes
38 x11-libs/libXext
39 x11-libs/libSM
40 x11-libs/libICE
41 x11-libs/libX11
42 x11-libs/libXau
43 x11-libs/libXdmcp
44 media-gfx/imagemagick
45 media-libs/libpng
46 media-libs/fontconfig
47 media-libs/freetype
48 dev-libs/libxml2
49 dev-libs/boost
50 app-text/aiksaurus
51 app-text/sgmltools-lite
52 virtual/aspell-dict
53 virtual/python
54 cups? ( virtual/lpr )
55 latex? (
56 virtual/latex-base
57 virtual/ghostscript
58 app-text/noweb
59 dev-tex/dvipost
60 dev-tex/chktex
61 || (
62 dev-tex/latex2html
63 dev-tex/tth
64 dev-tex/hevea
65 dev-tex/tex4ht
68 linguas_he? ( dev-tex/ivritex )"
70 DEPEND="${RDEPEND}
71 x11-proto/xproto
72 nls? ( sys-devel/gettext )"
74 S="${WORKDIR}"/${P}
76 src_unpack() {
77 unpack ${A}
78 subversion_fetch || die "Fetch with SVN failed kthnx."
79 cd "${S}"
80 epatch "${FILESDIR}"/${PN}-1.5.0-gentoo.patch || die
82 # trunk needs to regen with autotools
83 # lets use gentoo tools instead of the lyx script,
84 # which calls aclocal, autoheader, automake, autoconf
85 rm -rf "${S}"/autom4te.cache
86 eaclocal
87 eautoheader
88 eautomake
89 eautoconf
92 src_compile() {
93 append-flags "$(test-flags -fno-stack-protector -fno-stack-protector-all)"
94 replace-flags "-Os" "-O2"
95 tc-export CXX
97 unset LINGUAS
99 econf \
100 $(use_enable nls) \
101 $(use_enable debug) \
102 $(use_enable pch) \
103 --with-aspell --without-included-boost || die "econf failed"
104 emake || die "emake failed"
107 src_install() {
108 local mylinguas="${LINGUAS}"
110 unset LINGUAS
111 emake DESTDIR="${D}" install || die "emake install failed"
113 LINGUAS="${mylinguas}"
115 dodoc ANNOUNCE ChangeLog NEWS README RELEASE-NOTES UPGRADING
117 if use linguas_he ; then
118 insinto /usr/share/lyx/bind
119 doins "${DISTDIR}"/hebrew.bind
120 dodoc "${DISTDIR}"/preferences
123 domenu "${FILESDIR}"/lyx.desktop
125 cd "${WORKDIR}"/${FONT_P}
126 emake DESTDIR="${D}" install || die "Font installation failed"
128 font_src_install
130 if use latex ; then
131 dosym ../../../lyx/tex /usr/share/texmf/tex/latex/lyx
135 pkg_postinst() {
136 font_pkg_postinst
138 if use latex ; then
139 texhash
142 if use linguas_he ; then
143 elog
144 elog "How to use Hebrew in LyX:"
145 elog "bunzip2 /usr/share/doc/${PF}/preferences.bz2 into ~/.lyx/preferences"
146 elog "or, read http://cs.haifa.ac.il/~dekelts/lyx/instructions2.html"
147 elog "for instructions on using lyx's own preferences dialog to equal effect."
148 elog
151 elog
152 elog "There are known issues in the case of 1.4->1.5 config files transition."
153 elog "In case your File->Export list is incomplete try reconfiguring or even"
154 elog "remove the old configuration files in ~/.lyx ."
155 elog
158 pkg_postrm() {
159 if use latex ; then
160 texhash