app-misc/gnome-commander: 1.3.0.99 - adjust dep for app-doc/chmlib -> dev-libs/chmlib...
[gentoo-soor-overlay.git] / games-util / smithy / smithy-9999.ebuild
blob4dc17d4680f2bbbe6d8c353ff2acd0241c1f89c6
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit subversion
7 IUSE=""
9 DESCRIPTION="A map editor for AlephOne"
10 HOMEPAGE="http://smithy.sourceforge.net/"
11 LICENSE=""
13 DEPEND="dev-lang/ocaml
14 dev-ml/lablgl
15 dev-ml/lablgtk
16 dev-ml/ocaml-make"
18 SRC_URI=""
19 ESVN_REPO_URI="https://smithy.svn.sourceforge.net/svnroot/smithy"
20 SLOT="0"
21 KEYWORDS=""
23 pkg_setup() {
24 if ! built_with_use dev-ml/lablgtk opengl ; then
25 eerror "In order to build ${PN} you need to build lablgtk with"
26 eerror "OpenGL support."
27 eerror "You need to install dev-ml/lablgtk with opengl useflag on."
28 die "Please install lablgtk with opengl useflag"
31 if ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
32 eerror "In order to build ${PN}, you first need to have a native"
33 eerror "code ocaml compiler."
34 eerror "You need to install dev-lang/ocaml with ocamlopt useflag on."
35 die "Please install ocaml with ocamlopt useflag"
39 src_compile() {
40 # installation isn't really supported yet, so we have to hack this.
41 sed -e 's:resources/:/usr/share/games/smithy/:g' -i Resources.ml
43 # if you use emake smithy wont build. have fun figuring out why.
44 make
47 src_install () {
48 dobin smithy
50 insinto '/usr/share/games/smithy'
51 doins resources/*
53 dodoc docs/* examples/*