🎶 AND DON'T FORGET THE JOKER
[flussence-overlay.git] / x11-misc / picom / picom-9999-r6.ebuild
blobf6222e1533d26c8242a4a84db535f4e066aa1d87
1 # Copyright 2020-2024 Gentoo Authors
2 # Distributed under the terms of the GNU General Public License v2
4 EAPI=8
6 GITHUB_USER="yshui"
8 DESCRIPTION="Picom (née Compton) is an X compositor with XRender and OpenGL/ES 3.0 support."
9 LICENSE="MPL-2.0 MIT"
10 SLOT="0"
11 KEYWORDS="~amd64 ~x86"
12 IUSE="dbus drm +doc +libconfig +opengl +pcre"
14 inherit fcaps github-pkg meson xdg
16 if [[ ${PV} != "9999" ]]; then
17 MY_PV="${PV/_rc/-rc}"
18 SRC_URI="${GITHUB_HOMEPAGE}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
19 S="${WORKDIR}/${PN}-${MY_PV}"
22 RDEPEND="
23 dev-libs/libev
24 >=x11-libs/libxcb-1.9.2
25 x11-libs/libXext
26 x11-libs/libXdamage
27 x11-libs/libXrender
28 x11-libs/libXrandr
29 x11-libs/libXcomposite
30 x11-libs/pixman
31 x11-libs/xcb-util
32 x11-libs/xcb-util-image
33 x11-libs/xcb-util-renderutil
34 dbus? ( sys-apps/dbus )
35 drm? ( x11-libs/libdrm )
36 libconfig? ( >=dev-libs/libconfig-1.4:= )
37 opengl? ( media-libs/libepoxy )
38 pcre? ( dev-libs/libpcre2:= )"
39 DEPEND="${RDEPEND}
40 dev-libs/uthash"
41 BDEPEND="doc? ( app-text/asciidoc )"
43 FILECAPS=( -m 755 cap_sys_nice+ep "usr/bin/${PN}" )
45 src_configure() {
46 # TODO: support FEATURES=test properly
47 local emesonargs=(
48 "$(meson_use dbus)"
49 "$(meson_use doc with_docs)"
50 "$(meson_use drm vsync_drm)"
51 "$(meson_use libconfig config_file)"
52 "$(meson_use opengl)"
53 "$(meson_use pcre regex)"
54 "-Dcompton=false"
56 meson_src_configure
59 src_install() {
60 dodoc CONTRIBUTORS
62 docinto examples
63 dodoc ./*-fshader-win.glsl ./*.sample.conf
64 if use dbus; then
65 dodoc -r dbus-examples/
68 meson_src_install
71 pkg_postinst() {
72 xdg_pkg_postinst
73 fcaps_pkg_postinst