package/rpi-userland: don't install file in random location
[buildroot-gz.git] / package / libssh2 / libssh2.mk
blob847c2f1b8e530b6bbf80ad7338ea1469849dff24
1 ################################################################################
3 # libssh2
5 ################################################################################
7 LIBSSH2_VERSION = 1.7.0
8 LIBSSH2_SITE = http://www.libssh2.org/download
9 LIBSSH2_LICENSE = BSD
10 LIBSSH2_LICENSE_FILES = COPYING
11 LIBSSH2_INSTALL_STAGING = YES
12 LIBSSH2_CONF_OPTS = --disable-examples-build
14 # Dependency is either on libgcrypt or openssl, guaranteed in Config.in.
15 # Favour libgcrypt.
16 ifeq ($(BR2_PACKAGE_LIBGCRYPT),y)
17 LIBSSH2_DEPENDENCIES += libgcrypt
18 LIBSSH2_CONF_OPTS += --with-libgcrypt \
19 --with-libgcrypt-prefix=$(STAGING_DIR)/usr \
20 --without-openssl
21 # configure.ac forgets to link to dependent libraries of gcrypt breaking static
22 # linking
23 LIBSSH2_CONF_ENV += LIBS="`$(STAGING_DIR)/usr/bin/libgcrypt-config --libs`"
24 else
25 LIBSSH2_DEPENDENCIES += openssl
26 LIBSSH2_CONF_OPTS += --with-openssl \
27 --with-libssl-prefix=$(STAGING_DIR)/usr \
28 --without-libgcrypt
29 endif
31 # Add zlib support if enabled
32 ifeq ($(BR2_PACKAGE_ZLIB),y)
33 LIBSSH2_DEPENDENCIES += zlib
34 LIBSSH2_CONF_OPTS += --with-libz \
35 --with-libz-prefix=$(STAGING_DIR)/usr
36 else
37 LIBSSH2_CONF_OPTS += --without-libz
38 endif
40 $(eval $(autotools-package))