btrfs-progs: bump version to 4.8.3
[buildroot-gz.git] / package / jack2 / jack2.mk
blobfa9e451345ff26084a1331b2891f2728836a8322
1 ################################################################################
3 # jack2
5 ################################################################################
7 JACK2_VERSION = v1.9.10
8 JACK2_SITE = $(call github,jackaudio,jack2,$(JACK2_VERSION))
9 JACK2_LICENSE = GPLv2+ (jack server), LGPLv2.1+ (jack library)
10 JACK2_DEPENDENCIES = libsamplerate libsndfile alsa-lib host-python
11 JACK2_INSTALL_STAGING = YES
12 JACK2_PATCH = https://github.com/jackaudio/jack2/commit/ff1ed2c4524095055140370c1008a2d9cccc5645.patch
14 ifeq ($(BR2_PACKAGE_OPUS),y)
15 JACK2_DEPENDENCIES += opus
16 endif
18 ifeq ($(BR2_PACKAGE_READLINE),y)
19 JACK2_DEPENDENCIES += readline
20 endif
22 ifeq ($(BR2_PACKAGE_JACK2_LEGACY),y)
23 JACK2_CONF_OPTS += --classic
24 else
25 define JACK2_REMOVE_JACK_CONTROL
26 $(RM) -f $(TARGET_DIR)/usr/bin/jack_control
27 endef
28 JACK2_POST_INSTALL_TARGET_HOOKS += JACK2_REMOVE_JACK_CONTROL
29 endif
31 ifeq ($(BR2_PACKAGE_JACK2_DBUS),y)
32 JACK2_DEPENDENCIES += dbus
33 JACK2_CONF_OPTS += --dbus
34 endif
36 # Even though it advertises support for celt-0.5.x, jack2 really
37 # requires celt >= 0.5.2 but we only have 0.5.1.3 and we cannot
38 # upgrade, so we do not add a dependency to celt051, which it can't
39 # find anyway as it looks for celt.pc but we only have celt-51.pc.
41 # The dependency against eigen is only useful in conjunction with
42 # gtkiostream, which we do not have, so we don't need to depend on
43 # eigen.
45 define JACK2_CONFIGURE_CMDS
46 (cd $(@D); \
47 $(TARGET_CONFIGURE_OPTS) \
48 $(HOST_DIR)/usr/bin/python2 ./waf configure \
49 --prefix=/usr \
50 --alsa \
51 $(JACK2_CONF_OPTS) \
53 endef
55 define JACK2_BUILD_CMDS
56 (cd $(@D); \
57 $(TARGET_CONFIGURE_OPTS) \
58 $(HOST_DIR)/usr/bin/python2 ./waf build -j $(PARALLEL_JOBS))
59 endef
61 define JACK2_INSTALL_TARGET_CMDS
62 (cd $(@D); \
63 $(TARGET_CONFIGURE_OPTS) \
64 $(HOST_DIR)/usr/bin/python2 ./waf --destdir=$(TARGET_DIR) \
65 install)
66 endef
68 define JACK2_INSTALL_STAGING_CMDS
69 (cd $(@D); \
70 $(TARGET_CONFIGURE_OPTS) \
71 $(HOST_DIR)/usr/bin/python2 ./waf --destdir=$(STAGING_DIR) \
72 install)
73 endef
75 $(eval $(generic-package))