package/libraw: fix gcc-6 build
[buildroot-gz.git] / package / libraw / libraw.mk
blobd76a1808d5f6d3558575cbc12f92a7d0e1f11bcf
1 ################################################################################
3 # libraw
5 ################################################################################
7 LIBRAW_VERSION = 0.17.1
8 LIBRAW_SOURCE = LibRaw-$(LIBRAW_VERSION).tar.gz
9 LIBRAW_SITE = http://www.libraw.org/data
10 LIBRAW_PATCH = \
11 https://anonscm.debian.org/cgit/pkg-phototools/libraw.git/plain/debian/patches/0001-Fix_gcc6_narrowing_conversion.patch?id=d890937aaca6359df45a66b35e547c94ca564823
13 LIBRAW_INSTALL_STAGING = YES
14 # we patch configure.ac
15 LIBRAW_AUTORECONF = YES
16 LIBRAW_CONF_OPTS += \
17 --disable-examples \
18 --disable-openmp \
19 --disable-demosaic-pack-gpl2 \
20 --disable-demosaic-pack-gpl3
21 LIBRAW_LICENSE = LGPLv2.1 or CDDL 1.0 or LibRaw Software License 27032010
22 LIBRAW_LICENSE_FILES = LICENSE.LGPL LICENSE.CDDL LICENSE.LibRaw.pdf README
23 LIBRAW_DEPENDENCIES = host-pkgconf
25 ifeq ($(BR2_PACKAGE_JASPER),y)
26 LIBRAW_CONF_OPTS += --enable-jasper
27 LIBRAW_DEPENDENCIES += jasper
28 else
29 LIBRAW_CONF_OPTS += --disable-jasper
30 endif
32 ifeq ($(BR2_PACKAGE_JPEG),y)
33 LIBRAW_CONF_OPTS += --enable-jpeg
34 LIBRAW_DEPENDENCIES += jpeg
35 else
36 LIBRAW_CONF_OPTS += --disable-jpeg
37 endif
39 ifeq ($(BR2_PACKAGE_LCMS2),y)
40 LIBRAW_CONF_OPTS += --enable-lcms
41 LIBRAW_DEPENDENCIES += lcms2 host-pkgconf
42 else
43 LIBRAW_CONF_OPTS += --disable-lcms
44 endif
46 $(eval $(autotools-package))