qemu: bump version to 2.7.0
[buildroot-gz.git] / package / libgpgme / libgpgme.mk
blob574ddd6be14d4c4dda76c94ec3f09d2c2bcdb3ae
1 ################################################################################
3 # libgpgme
5 ################################################################################
7 LIBGPGME_VERSION = 1.5.5
8 LIBGPGME_SITE = ftp://ftp.gnupg.org/gcrypt/gpgme
9 LIBGPGME_SOURCE = gpgme-$(LIBGPGME_VERSION).tar.bz2
10 LIBGPGME_LICENSE = LGPLv2.1+
11 LIBGPGME_LICENSE_FILES = COPYING.LESSER
12 LIBGPGME_INSTALL_STAGING = YES
13 LIBGPGME_DEPENDENCIES = libassuan libgpg-error
15 # libgpgme, needs to know the gpg binary path on the target.
16 LIBGPGME_CONF_OPTS = --with-gpg=/usr/bin/gpg \
17 --with-gpg-error-prefix=$(STAGING_DIR)/usr \
18 --with-libassuan-prefix=$(STAGING_DIR)/usr \
19 --disable-gpgsm-test \
20 --disable-gpgconf-test \
21 --disable-g13-test \
22 --disable-gpg-test
24 # Handle argp-standalone or it errors out during build
25 ifeq ($(BR2_PACKAGE_ARGP_STANDALONE),y)
26 # musl libc does not define error_t in errno.h, but argp.h does.
27 # Assume we have error_t to avoid collision with the argp.h error_t.
28 LIBGPGME_CONF_ENV += LIBS="-largp" ac_cv_type_error_t=yes
29 LIBGPGME_DEPENDENCIES += argp-standalone
30 endif
32 $(eval $(autotools-package))