syslog-ng: Bump version to 3.7.3
[buildroot-gz.git] / package / duma / duma.mk
blob5e862ab25ecbbd27c5f82d0b67ef31bf4dc7f522
1 ################################################################################
3 # duma
5 ################################################################################
7 DUMA_VERSION = 2.5.15
8 DUMA_SOURCE = duma_$(subst .,_,$(DUMA_VERSION)).tar.gz
9 DUMA_SITE = http://downloads.sourceforge.net/project/duma/duma/$(DUMA_VERSION)
10 DUMA_LICENSE = GPLv2+ LGPLv2.1+
11 DUMA_LICENSE_FILES = COPYING-GPL COPYING-LGPL
13 DUMA_INSTALL_STAGING = YES
15 DUMA_OPTIONS = \
16 $(if $(BR2_PACKAGE_DUMA_NO_LEAKDETECTION),-DDUMA_LIB_NO_LEAKDETECTION)
18 # The dependency of some source files in duma_config.h, which is generated at
19 # build time, is not specified in the Makefile. Force non-parallel build.
20 define DUMA_BUILD_CMDS
21 $(MAKE1) $(TARGET_CONFIGURE_OPTS) \
22 OS=linux \
23 DUMA_OPTIONS="$(DUMA_OPTIONS)" \
24 $(DUMA_CPP) -C $(@D)
25 endef
27 define DUMA_INSTALL_STAGING_CMDS
28 $(MAKE) OS=linux prefix=$(STAGING_DIR)/usr install -C $(@D)
29 endef
31 define DUMA_INSTALL_TARGET_CMDS
32 $(MAKE) OS=linux prefix=$(TARGET_DIR)/usr install -C $(@D)
33 endef
35 $(eval $(generic-package))