Mention autogen.sh sooner in doc
[autoconf.git] / shell.nix
blobfd22b8fff71b61bd4a7fbe7b13a4e115585f6442
1 { pkgs ? import <nixpkgs> {} }:
2 pkgs.mkShell {
3   # included by default (since we're not using mkShellNoCC) are:
4   #    bash coreutils file findutils gawk gnugrep gnused
5   #    gnutar gzip bzip2 xz diffutils patch
6   #    binutils gcc glibc gnumake
7   packages = with pkgs;
8     # custom texliveBasic - metafont and ectt are required to build PDF documentation
9     let
10        texliveCustom = texliveBasic.withPackages (ps: [ps.metafont ps.ec]);
11     in [
12       # Additional requirements for building and running Autoconf itself
13       m4
14       perl
16       # Additional requirements for building from a pristine git checkout
17       automake
18       git
19       help2man
20       texinfo
21       texliveCustom
23       # Needed only to run the test suite comprehensively
24       # TODO: Make a variant that uses mkShellNoCC and *doesn't* install any
25       # of this and ensure that every test that probes some of them is
26       # skipped, rather than failing, when run in that environment.
27       # Currently lots of tests fail in the absence of a C compiler.
29       # Compilers and tools that Autoconf is capable of probing
30       bison
31       erlang
32       flex
33       gccgo
34       gfortran
35       libtool
36       # Objective-C compiler seems not to be available
37       # shtool is not available
39       # Needed to test AC_CHECK_LIB and AC_SEARCH_LIBS
40       zlib
42   ];