tevent: avoid any operation on epoll_ev after a epoll_panic()
[Samba/gebeck_regimport.git] / packaging / LSB / lsb-samba.spec
blob516eaa430ebd923c01ec92b91404500dca0ab5f8
2 # "$Id: lsb-samba.spec,v 1.2 2001/07/03 01:01:12 jra Exp $"
4 # Linux Standards Based RPM "spec" file for SAMBA.
7 Summary: SAMBA
8 Name: lsb-samba
9 Version: 2.2.1
10 Release: 0
11 Copyright: GPL
12 Group: System Environment/Daemons
13 Source: ftp://ftp.samba.org/pub/samba/samba-%{version}.tar.gz
14 Url: http://www.samba.org
15 Packager: Michael Sweet <mike@easysw.com>
16 Vendor: SAMBA Team
18 # Require the "lsb" package, which guarantees LSB compliance.
19 Requires: lsb
21 # use BuildRoot so as not to disturb the version already installed
22 BuildRoot: /var/tmp/%{name}-root
24 %description
26 %prep
27 %setup
29 %build
30 export LDFLAGS="-L/usr/lib/lsb --dynamic-linker=/lib/ld-lsb.so.1"
32 ./configure --with-fhs --prefix=/usr --sysconfdir=/etc \
33 --sharedstatedir=/var --datadir=/usr/share \
34 --with-configdir=/etc/samba \
35 --with-swatdir=/usr/share/samba/swat
37 # If we got this far, all prerequisite libraries must be here.
38 make
40 %install
41 # Make sure the RPM_BUILD_ROOT directory exists.
42 rm -rf $RPM_BUILD_ROOT
43 mkdir $RPM_BUILD_ROOT
45 make \
46 BASEDIR=$RPM_BUILD_ROOT/usr \
47 BINDIR=$RPM_BUILD_ROOT/usr/bin \
48 CODEPAGEDIR=$RPM_BUILD_ROOT/usr/share/samba/codepages \
49 CONFIGDIR=$RPM_BUILD_ROOT/etc/samba \
50 INCLUDEDIR=$RPM_BUILD_ROOT/usr/include \
51 LIBDIR=$RPM_BUILD_ROOT/usr/lib \
52 LOCKDIR=$RPM_BUILD_ROOT/var/lock/samba \
53 LOGFILEBASE=$RPM_BUILD_ROOT/var/log/samba \
54 MANDIR=$RPM_BUILD_ROOT/usr/share/man \
55 SBINDIR=$RPM_BUILD_ROOT/usr/sbin \
56 SWATDIR=$RPM_BUILD_ROOT/usr/share/samba/swat \
57 VARDIR=$RPM_BUILD_ROOT/var \
58 install
60 mkdir -p $RPM_BUILD_ROOT/etc/init.d
61 install -m 700 packaging/LSB/samba.sh /etc/init.d/samba
63 mkdir -p $RPM_BUILD_ROOT/etc/samba
64 install -m 644 packaging/LSB/smb.conf /etc/samba
66 mkdir -p $RPM_BUILD_ROOT/etc/xinetd.d
67 install -m 644 packaging/LSB/samba.xinetd /etc/xinetd.d/samba
69 %post
70 /usr/lib/lsb/install_initd /etc/init.d/samba
72 %preun
73 /usr/lib/lsb/remove_initd /etc/init.d/samba
75 %clean
76 rm -rf $RPM_BUILD_ROOT
78 %files
79 %defattr(-,root,root)
80 %dir /etc/init.d
81 /etc/init.d/samba
82 %dir /etc/samba
83 %config(noreplace) /etc/samba/smb.conf
84 %dir /etc/samba/private
85 %dir /etc/xinetd.d
86 %config(noreplace) /etc/xinetd.d/samba
87 %dir /usr/bin
88 /usr/bin/*
89 %dir /usr/sbin
90 /usr/sbin/*
91 %dir /usr/share/man
92 /usr/share/man/*
93 %dir /usr/share/samba
94 /usr/share/samba/*
95 %dir /var/lock/samba
96 %dir /var/log/samba
99 # End of "$Id: lsb-samba.spec,v 1.2 2001/07/03 01:01:12 jra Exp $".