add old ebuilds from svn ub0rlay
[ub0rlay.git] / sci-geosciences / tah / tah-9999.ebuild
blobca38f7afc6687910bfa899974705ea65ab6e9622
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils subversion
7 DESCRIPTION="Tiles@home (short: T@H or t@h) is a distributed program to render
8 osmarender maps."
9 HOMEPAGE="http://tah.openstreetmap.org/"
10 SRC_URI=""
12 ESVN_REPO_URI="http://svn.openstreetmap.org/applications/rendering/tilesAtHome/"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~x86"
17 IUSE=""
19 DEPEND=""
20 RDEPEND="virtual/perl-File-Spec dev-perl/Math-VecStat dev-perl/libwww-perl
21 dev-perl/GD app-text/xmlstarlet dev-perl/Math-Vec media-gfx/pngcrush
22 media-gfx/inkscape
23 app-arch/zip app-arch/unzip
24 media-fonts/dejavu"
27 pkg_setup(){
28 if ! built_with_use dev-perl/GD png; then
29 eerror " "
30 eerror "you need to compile dev-perl/GD with png useflag "
31 eerror " "
32 die "dev-perl/GD is emerged without png useflag!"
36 src_install() {
37 patch < ${FILESDIR}/local_conf.patch
38 #dodir /opt/${PN}
40 insinto /opt/${PN}
41 doins -r *
43 exeinto /opt/${PN}
44 doexe *.pl
46 exeinto /opt/bin
47 doexe ${FILESDIR}/tilesGen