add old ebuilds from svn ub0rlay
[ub0rlay.git] / games-engines / indiana / indiana-0.0.3.ebuild
blob502a131cec4eb5291cdf089a4af2e881f36bf01e
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit games
7 DESCRIPTION="crossplatform point'n'click adventure engine in D using sdl"
8 HOMEPAGE="http://www.leetless.de/indiana/index.html"
9 SRC_URI="http://www.leetless.de/archives/indiana/releases/${P}.tar.gz"
11 LICENSE="GPL-3"
12 SLOT="0"
13 KEYWORDS="~amd64"
14 IUSE=""
16 DEPEND="dev-util/dsss
17 ${RDEPEND}"
19 RDEPEND="media-libs/libsdl
20 media-libs/sdl-image
21 media-libs/sdl-gfx
22 media-libs/sdl-ttf
23 media-libs/sdl-mixer"
25 pkg_setup(){
27 if ! built_with_use sys-devel/gcc d; then
28 eerror " "
29 eerror "you need to compile sys-devel/gcc with d useflag "
30 eerror " "
31 die "No suitable D compiler found!"
35 src_compile(){
37 cd ${PN}
38 dsss build --prefix=${D}/usr || die "build failed"
41 src_install(){
43 cd ${PN}
44 dsss install --prefix=${D}/usr || die "install failed"