9e7621e04994345e33f173dd61740d079a0963fd
[ub0rlay.git] / sci-geosciences / tah / tah-9999-r2.ebuild
blob9e7621e04994345e33f173dd61740d079a0963fd
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 inherit eutils subversion
7 DESCRIPTION="Tiles@home (short: T@H or t@h) is a distributed program to render
8 osmarender maps."
9 HOMEPAGE="http://tah.openstreetmap.org/"
10 SRC_URI=""
12 ESVN_REPO_URI="http://svn.openstreetmap.org/applications/rendering/tilesAtHome/"
14 LICENSE="GPL-2"
15 SLOT="0"
16 KEYWORDS="~amd64 ~x86"
17 IUSE=""
19 DEPEND=""
20 RDEPEND="virtual/perl-File-Spec dev-perl/Math-VecStat dev-perl/libwww-perl
21 dev-perl/GD app-text/xmlstarlet dev-perl/Math-Vec media-gfx/pngcrush
22 media-gfx/inkscape
23 app-arch/zip app-arch/unzip
24 media-fonts/dejavu
25 dev-perl/AppConfig"
28 pkg_setup(){
29 if ! built_with_use dev-perl/GD png; then
30 eerror " "
31 eerror "you need to compile dev-perl/GD with png useflag "
32 eerror " "
33 die "dev-perl/GD is emerged without png useflag!"
37 src_install() {
38 patch < ${FILESDIR}/local_conf-2.patch
39 diropts -m2770
40 dodir /opt/${PN}
41 fowners root:users /opt/${PN}
43 insinto /opt/${PN}
44 insopts -m660
45 doins -r *
47 exeinto /opt/${PN}
48 exeopts -m750
49 doexe *.pl
51 exeinto /opt/bin
52 doexe ${FILESDIR}/tilesGen
53 fowners root:users /opt/bin/tilesGen