Updated to release 1.11.2 (Another Bugfixes release only)
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob6cdbc2f01f1eeeb2248162753d3546c243cb4073
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define pkg_group Applications/Internet
22 Name: pidgin-sipe
23 Summary: Pidgin protocol plugin to connect to MS Office Communicator
24 Version: 1.11.2
25 %if 0%{?_with_git:1}
26 Release: %{gitcount}.%{git}%{?dist}
27 Source: %{name}-%{git}.tar.bz2
28 # git package overrides official released package
29 Epoch: 1
30 %else
31 Release: 1%{?dist}
32 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
33 %endif
34 Group: %{pkg_group}
35 License: GPLv2+
36 URL: http://sipe.sourceforge.net/
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40 BuildRequires: libpurple-devel >= 2.4.0
41 BuildRequires: glib2-devel >= 2.12.0
42 BuildRequires: libxml2-devel
43 #BuildRequires: nss-devel
44 BuildRequires: libtool
45 BuildRequires: intltool
46 BuildRequires: gettext-devel
47 #BuildRequires: libnice-devel
49 # Configurable components
50 %if !0%{?_without_kerberos:1}
51 BuildRequires: krb5-devel
52 %endif
54 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
57 %description
58 A third-party plugin for the Pidgin multi-protocol instant messenger.
59 It implements the extended version of SIP/SIMPLE used by various products:
61 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
62 * Microsoft Live Communications Server (LCS 2003/2005)
63 * Reuters Messaging
65 With this plugin you should be able to replace your Microsoft Office
66 Communicator client with Pidgin.
68 This package provides the icon set for Pidgin.
71 %package -n %{purple_plugin}
72 Summary: Libpurple protocol plugin to connect to MS Office Communicator
73 Group: %{pkg_group}
74 License: GPLv2+
76 %description -n %{purple_plugin}
77 A third-party plugin for the Pidgin multi-protocol instant messenger.
78 It implements the extended version of SIP/SIMPLE used by various products:
80 * Microsoft Office Communications Server (OCS 2007/2007 R2 and newer)
81 * Microsoft Live Communications Server (LCS 2003/2005)
82 * Reuters Messaging
84 This package provides the protocol plugin for libpurple clients.
87 %prep
88 %if 0%{?_with_git:1}
89 %setup -q -n %{name}-%{git}
90 %else
91 %setup -q
92 %endif
95 %build
96 %if 0%{?_with_git:1}
97 ./autogen.sh
98 %endif
99 %configure \
100 --enable-purple \
101 --disable-telepathy
102 make %{_smp_mflags}
103 make %{_smp_mflags} check
106 %install
107 %makeinstall
108 find %{buildroot} -type f -name "*.la" -delete -print
109 %find_lang %{name}
112 %clean
113 rm -rf %{buildroot}
116 %files -n %{purple_plugin} -f %{name}.lang
117 %defattr(-,root,root,-)
118 %doc AUTHORS ChangeLog COPYING NEWS README TODO
119 %{_libdir}/purple-2/libsipe.so
122 %files
123 %defattr(-,root,root,-)
124 %doc AUTHORS COPYING
125 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
126 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
129 %changelog
130 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
131 - update to 1.11.2
133 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
134 - update to 1.11.1
136 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
137 - add (commented out) BR libnice-devel
139 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
140 - update to 1.10.1
142 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
143 - add (commented out) BR nss-devel
145 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
146 - update to 1.10.0
148 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
149 - changed --with/--without options to --enable/--disable
151 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
152 - removed --with-krb5 configure option as it is autodetected now
154 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
155 - add SVG icon
157 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
158 - add BR glib2-devel >= 2.12.0
160 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
161 - add tests to build
163 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
164 - update to 1.9.1
166 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
167 - add BR libxml2-devel
169 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
170 - update to 1.9.0
172 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
173 - increased libpurple build requisite to >= 2.4.0
175 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
176 - sync with RPM SPEC from contrib/OBS
178 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
179 - update package summary & description
181 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
182 - update to 1.8.1
184 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
185 - update to 1.8.0
187 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
188 - autogen.sh no longer runs configure
190 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
191 - add configure parameters for purple and telepathy
193 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
194 - add Epoch: for git packages to avoid update clash with official packages
196 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
197 - update to 1.7.1
199 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
200 - add missing Group: to purple-sipe
202 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
203 - update to 1.7.0
205 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
206 - move non-Pidgin files to new sub-package purple-sipe
208 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
209 - remove directory for emoticon theme icons
211 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
212 - libpurple protocol plugins are located under %{_libdir}/purple-2
214 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
215 - added directory for emoticon theme icons
217 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
218 - update to 1.6.3
220 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
221 - reduce libpurple-devel requirement to >= 2.3.1
223 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
224 - update to 1.6.2
226 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
227 - reduce libpurple-devel requirement to >= 2.4.1
229 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
230 - com_err.h only required for kerberos
232 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
233 - require libpurple-devel >= 2.5.0
235 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
236 - refactor configure parameters
237 - make kerberos configurable
238 - don't hard code prefix for git builds
240 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
241 - removed unnecessary zlib-devel
243 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
244 - fix prefix for git builds
246 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
247 - append -Wno-unused-parameter for GCC <4.4 compilation errors
249 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
250 - remove duplicate GPL2
252 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
253 - use "--with git" to build from git
254 - corrected download URL for release archive
255 - add missing BR gettext-devel
257 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
258 - use default rpmbuild CFLAGS also for git builds
259 - merge with SPEC files created by mricon & jberanek
261 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
262 - initial RPM SPEC example generated