f853705c2aefec5f1392340de1af63d6da29f612
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blobf853705c2aefec5f1392340de1af63d6da29f612
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20120905gitcc6065b
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.17.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: libpurple-devel >= 2.4.0
45 BuildRequires: glib2-devel >= 2.12.0
46 BuildRequires: gmime-devel
47 BuildRequires: libxml2-devel
48 BuildRequires: nss-devel
49 BuildRequires: libtool
50 BuildRequires: intltool
51 BuildRequires: gettext-devel
52 # Use "--with vv" to enable Voice & Video features
53 %if 0%{?_with_vv:1}
54 BuildRequires: libpurple-devel >= 2.8.0
55 BuildRequires: libnice-devel >= 0.1.0
56 BuildRequires: gstreamer-devel
57 %endif
58 # Use "--without telepathy" to disable telepathy
59 %if !0%{?_without_telepathy:1}
60 BuildRequires: telepathy-glib-devel >= 0.18.0
61 BuildRequires: glib2-devel >= 2.28.0
62 %endif
64 # Configurable components
65 # Use "--without kerberos" to disable krb5
66 %if !0%{?_without_kerberos:1}
67 BuildRequires: krb5-devel
68 %endif
70 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
73 %description
74 A third-party plugin for the Pidgin multi-protocol instant messenger.
75 It implements the extended version of SIP/SIMPLE used by various products:
77 * Microsoft Office 365
78 * Microsoft Business Productivity Online Suite (BPOS)
79 * Microsoft Lync Server
80 * Microsoft Office Communications Server (OCS 2007/2007 R2)
81 * Microsoft Live Communications Server (LCS 2003/2005)
82 * Reuters Messaging
84 With this plugin you should be able to replace your Microsoft Office
85 Communicator client with Pidgin.
87 This package provides the icon set for Pidgin.
90 %package -n %{purple_plugin}
91 Summary: Libpurple protocol plugin to connect to MS Office Communicator
92 Group: %{pkg_group}
93 License: GPL-2.0+
94 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
96 %description -n %{purple_plugin}
97 A third-party plugin for the Pidgin multi-protocol instant messenger.
98 It implements the extended version of SIP/SIMPLE used by various products:
100 * Microsoft Office 365
101 * Microsoft Business Productivity Online Suite (BPOS)
102 * Microsoft Lync Server
103 * Microsoft Office Communications Server (OCS 2007/2007 R2)
104 * Microsoft Live Communications Server (LCS 2003/2005)
105 * Reuters Messaging
107 This package provides the protocol plugin for libpurple clients.
110 %if !0%{?_without_telepathy:1}
111 %package -n %{empathy_files}
112 Summary: Telepathy connection manager to connect to MS Office Communicator
113 Group: %{pkg_group}
114 License: GPL-2.0+
115 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
117 %description -n %{empathy_files}
118 A Telepathy connection manager that implements the extended version of
119 SIP/SIMPLE used by various products:
121 * Microsoft Office 365
122 * Microsoft Business Productivity Online Suite (BPOS)
123 * Microsoft Lync Server
124 * Microsoft Office Communications Server (OCS 2007/2007 R2)
125 * Microsoft Live Communications Server (LCS 2003/2005)
126 * Reuters Messaging
128 This package provides the icon set for Empathy.
131 %package -n %{ktp_files}
132 Summary: Telepathy connection manager to connect to MS Office Communicator
133 Group: %{pkg_group}
134 License: GPL-2.0+
135 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
137 %description -n %{ktp_files}
138 A Telepathy connection manager that implements the extended version of
139 SIP/SIMPLE used by various products:
141 * Microsoft Office 365
142 * Microsoft Business Productivity Online Suite (BPOS)
143 * Microsoft Lync Server
144 * Microsoft Office Communications Server (OCS 2007/2007 R2)
145 * Microsoft Live Communications Server (LCS 2003/2005)
146 * Reuters Messaging
148 This package provides the profile for KTP account manager.
151 %package -n %{telepathy_plugin}
152 Summary: Telepathy connection manager to connect to MS Office Communicator
153 Group: %{pkg_group}
154 License: GPL-2.0+
155 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
157 %description -n %{telepathy_plugin}
158 A Telepathy connection manager that implements the extended version of
159 SIP/SIMPLE used by various products:
161 * Microsoft Office 365
162 * Microsoft Business Productivity Online Suite (BPOS)
163 * Microsoft Lync Server
164 * Microsoft Office Communications Server (OCS 2007/2007 R2)
165 * Microsoft Live Communications Server (LCS 2003/2005)
166 * Reuters Messaging
168 This package provides the protocol support for Telepathy clients.
169 %endif
172 %package -n %{common_files}
173 Summary: Common files for SIPE protocol plugins
174 Group: %{pkg_group}
175 License: GPL-2.0+
176 BuildArch: noarch
178 %description -n %{common_files}
179 This package provides common files for the SIPE protocol plugins:
181 * Localisation
184 %prep
185 %if 0%{?_with_git:1}
186 %setup -q -n %{name}-%{git}
187 %else
188 %setup -q
189 %endif
192 %build
193 %if 0%{?_with_git:1}
194 ./autogen.sh
195 %endif
196 %configure \
197 --enable-purple \
198 %if !0%{?_without_telepathy:1}
199 --enable-telepathy
200 %else
201 --disable-telepathy
202 %endif
203 make %{_smp_mflags}
204 make %{_smp_mflags} check
207 %install
208 %makeinstall
209 find %{buildroot} -type f -name "*.la" -delete -print
210 # Pidgin doesn't have 24 or 32 pixel icons
211 rm -f \
212 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
213 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
214 %find_lang %{name}
217 %clean
218 rm -rf %{buildroot}
221 %files -n %{purple_plugin}
222 %defattr(-,root,root,-)
223 %doc AUTHORS ChangeLog COPYING NEWS README TODO
224 %{_libdir}/purple-2/libsipe.so
227 %if !0%{?_without_telepathy:1}
228 %files -n %{empathy_files}
229 %defattr(-,root,root,-)
230 %doc AUTHORS COPYING
231 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
232 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
235 %files -n %{ktp_files}
236 %defattr(-,root,root,-)
237 %doc AUTHORS COPYING
238 %{_datadir}/telepathy/profiles/sipe.profile
241 %files -n %{telepathy_plugin}
242 %defattr(-,root,root,-)
243 %doc AUTHORS ChangeLog COPYING NEWS README TODO
244 %{_datadir}/dbus-1/services/*.sipe.service
245 %{_libexecdir}/telepathy-sipe
246 %endif
249 %files -n %{common_files} -f %{name}.lang
250 %defattr(-,root,root,-)
253 %files
254 %defattr(-,root,root,-)
255 %doc AUTHORS COPYING
256 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
257 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
260 %changelog
261 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
262 - update to 1.17.1
264 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
265 - update to 1.17.0
267 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
268 - update to 1.16.1
270 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
271 - update to 1.16.0
273 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
274 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
276 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
277 - update to 1.15.1
279 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
280 - update package description texts
282 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
283 - update to 1.15.0
285 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
286 - update to 1.14.1
288 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
289 - update to 1.14.0
291 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
292 - BR telepathy-glib-devel >= 0.18.0
294 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
295 - BR telepathy-glib-devel >= 0.14.0
297 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
298 - add ktp-accounts-kcm-sipe package
300 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
301 - telepathy now requires glib-2.0 >= 2.22.0
302 - use "--without telepathy" to disable telepathy packages
304 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
305 - add empathy-sipe package
307 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
308 - add telepathy-sipe & sipe-common packages
310 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
311 - update to 1.13.3
313 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
314 - update to 1.13.2
316 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
317 - update to 1.13.1
319 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
320 - update to 1.13.0
322 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
323 - we do support Microsoft Lync Server 2010 now.
325 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
326 - update GPL2 license name
328 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
329 - add BR gmime-devel
331 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
332 - add BR nss-devel
334 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
335 - update to 1.12.0
337 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
338 - add "--with vv" option to enable Voice & Video features
340 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
341 - update to 1.11.2
343 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
344 - update to 1.11.1
346 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
347 - update to 1.11.0
349 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
350 - add (commented out) BR libnice-devel
352 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
353 - update to 1.10.1
355 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
356 - add (commented out) BR nss-devel
358 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
359 - update to 1.10.0
361 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
362 - changed --with/--without options to --enable/--disable
364 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
365 - removed --with-krb5 configure option as it is autodetected now
367 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
368 - add SVG icon
370 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
371 - add BR glib2-devel >= 2.12.0
373 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
374 - add tests to build
376 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
377 - update to 1.9.1
379 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
380 - add BR libxml2-devel
382 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
383 - update to 1.9.0
385 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
386 - increased libpurple build requisite to >= 2.4.0
388 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
389 - sync with RPM SPEC from contrib/OBS
391 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
392 - update package summary & description
394 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
395 - update to 1.8.1
397 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
398 - update to 1.8.0
400 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
401 - autogen.sh no longer runs configure
403 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
404 - add configure parameters for purple and telepathy
406 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
407 - add Epoch: for git packages to avoid update clash with official packages
409 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
410 - update to 1.7.1
412 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
413 - add missing Group: to purple-sipe
415 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
416 - update to 1.7.0
418 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
419 - move non-Pidgin files to new sub-package purple-sipe
421 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
422 - remove directory for emoticon theme icons
424 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
425 - libpurple protocol plugins are located under %{_libdir}/purple-2
427 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
428 - added directory for emoticon theme icons
430 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
431 - update to 1.6.3
433 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
434 - reduce libpurple-devel requirement to >= 2.3.1
436 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
437 - update to 1.6.2
439 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
440 - reduce libpurple-devel requirement to >= 2.4.1
442 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
443 - com_err.h only required for kerberos
445 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
446 - require libpurple-devel >= 2.5.0
448 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
449 - refactor configure parameters
450 - make kerberos configurable
451 - don't hard code prefix for git builds
453 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
454 - removed unnecessary zlib-devel
456 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
457 - fix prefix for git builds
459 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
460 - append -Wno-unused-parameter for GCC <4.4 compilation errors
462 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
463 - remove duplicate GPL2
465 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
466 - use "--with git" to build from git
467 - corrected download URL for release archive
468 - add missing BR gettext-devel
470 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
471 - use default rpmbuild CFLAGS also for git builds
472 - merge with SPEC files created by mricon & jberanek
474 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
475 - initial RPM SPEC example generated