Release 1.13.3 -- Bug Fixes III
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob72843ff5e1abdabae2ac80b0354b0bc726c46bb3
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10/11 and RHEL5.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20100207git96eee8a
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define pkg_group Applications/Internet
22 Name: pidgin-sipe
23 Summary: Pidgin protocol plugin to connect to MS Office Communicator
24 Version: 1.13.3
25 %if 0%{?_with_git:1}
26 Release: %{gitcount}.%{git}%{?dist}
27 Source: %{name}-%{git}.tar.bz2
28 # git package overrides official released package
29 Epoch: 1
30 %else
31 Release: 1%{?dist}
32 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
33 %endif
34 Group: %{pkg_group}
35 License: GPL-2.0+
36 URL: http://sipe.sourceforge.net/
38 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
40 BuildRequires: libpurple-devel >= 2.4.0
41 BuildRequires: glib2-devel >= 2.12.0
42 BuildRequires: gmime-devel
43 BuildRequires: libxml2-devel
44 BuildRequires: nss-devel
45 BuildRequires: libtool
46 BuildRequires: intltool
47 BuildRequires: gettext-devel
48 # Use "--with vv" to enable Voice & Video features
49 %if 0%{?_with_vv:1}
50 BuildRequires: libpurple-devel >= 2.8.0
51 BuildRequires: glib2-devel >= 2.28.0
52 BuildRequires: libnice-devel >= 0.1.0
53 BuildRequires: gstreamer-devel
54 %endif
56 # Configurable components
57 %if !0%{?_without_kerberos:1}
58 BuildRequires: krb5-devel
59 %endif
61 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
64 %description
65 A third-party plugin for the Pidgin multi-protocol instant messenger.
66 It implements the extended version of SIP/SIMPLE used by various products:
68 * Microsoft Lync Server 2010
69 * Microsoft Office Communications Server (OCS 2007/2007 R2)
70 * Microsoft Live Communications Server (LCS 2003/2005)
71 * Reuters Messaging
73 With this plugin you should be able to replace your Microsoft Office
74 Communicator client with Pidgin.
76 This package provides the icon set for Pidgin.
79 %package -n %{purple_plugin}
80 Summary: Libpurple protocol plugin to connect to MS Office Communicator
81 Group: %{pkg_group}
82 License: GPL-2.0+
84 %description -n %{purple_plugin}
85 A third-party plugin for the Pidgin multi-protocol instant messenger.
86 It implements the extended version of SIP/SIMPLE used by various products:
88 * Microsoft Lync Server 2010
89 * Microsoft Office Communications Server (OCS 2007/2007 R2)
90 * Microsoft Live Communications Server (LCS 2003/2005)
91 * Reuters Messaging
93 This package provides the protocol plugin for libpurple clients.
96 %prep
97 %if 0%{?_with_git:1}
98 %setup -q -n %{name}-%{git}
99 %else
100 %setup -q
101 %endif
104 %build
105 %if 0%{?_with_git:1}
106 ./autogen.sh
107 %endif
108 %configure \
109 --enable-purple \
110 --disable-telepathy
111 make %{_smp_mflags}
112 make %{_smp_mflags} check
115 %install
116 %makeinstall
117 find %{buildroot} -type f -name "*.la" -delete -print
118 %find_lang %{name}
121 %clean
122 rm -rf %{buildroot}
125 %files -n %{purple_plugin} -f %{name}.lang
126 %defattr(-,root,root,-)
127 %doc AUTHORS ChangeLog COPYING NEWS README TODO
128 %{_libdir}/purple-2/libsipe.so
131 %files
132 %defattr(-,root,root,-)
133 %doc AUTHORS COPYING
134 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
135 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
138 %changelog
139 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
140 - update to 1.13.3
142 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
143 - update to 1.13.2
145 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
146 - update to 1.13.1
148 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
149 - update to 1.13.0
151 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
152 - we do support Microsoft Lync Server 2010 now.
154 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
155 - update GPL2 license name
157 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
158 - add BR gmime-devel
160 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
161 - add BR nss-devel
163 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
164 - update to 1.12.0
166 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
167 - add "--with vv" option to enable Voice & Video features
169 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
170 - update to 1.11.2
172 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
173 - update to 1.11.1
175 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
176 - update to 1.11.0
178 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
179 - add (commented out) BR libnice-devel
181 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
182 - update to 1.10.1
184 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
185 - add (commented out) BR nss-devel
187 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
188 - update to 1.10.0
190 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
191 - changed --with/--without options to --enable/--disable
193 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
194 - removed --with-krb5 configure option as it is autodetected now
196 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
197 - add SVG icon
199 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
200 - add BR glib2-devel >= 2.12.0
202 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
203 - add tests to build
205 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
206 - update to 1.9.1
208 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
209 - add BR libxml2-devel
211 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
212 - update to 1.9.0
214 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
215 - increased libpurple build requisite to >= 2.4.0
217 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
218 - sync with RPM SPEC from contrib/OBS
220 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
221 - update package summary & description
223 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
224 - update to 1.8.1
226 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
227 - update to 1.8.0
229 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
230 - autogen.sh no longer runs configure
232 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
233 - add configure parameters for purple and telepathy
235 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
236 - add Epoch: for git packages to avoid update clash with official packages
238 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
239 - update to 1.7.1
241 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
242 - add missing Group: to purple-sipe
244 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
245 - update to 1.7.0
247 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
248 - move non-Pidgin files to new sub-package purple-sipe
250 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
251 - remove directory for emoticon theme icons
253 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
254 - libpurple protocol plugins are located under %{_libdir}/purple-2
256 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
257 - added directory for emoticon theme icons
259 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
260 - update to 1.6.3
262 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
263 - reduce libpurple-devel requirement to >= 2.3.1
265 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
266 - update to 1.6.2
268 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
269 - reduce libpurple-devel requirement to >= 2.4.1
271 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
272 - com_err.h only required for kerberos
274 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
275 - require libpurple-devel >= 2.5.0
277 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
278 - refactor configure parameters
279 - make kerberos configurable
280 - don't hard code prefix for git builds
282 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
283 - removed unnecessary zlib-devel
285 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
286 - fix prefix for git builds
288 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
289 - append -Wno-unused-parameter for GCC <4.4 compilation errors
291 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
292 - remove duplicate GPL2
294 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
295 - use "--with git" to build from git
296 - corrected download URL for release archive
297 - add missing BR gettext-devel
299 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
300 - use default rpmbuild CFLAGS also for git builds
301 - merge with SPEC files created by mricon & jberanek
303 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
304 - initial RPM SPEC example generated