Release 1.14.0 -- Buddy photo & ADFS support, Web Ticket Optimizations
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob72a95b8ee179f3d3cbc014579d3ac37c8d0e9b37
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20120905gitcc6065b
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.14.0
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: libpurple-devel >= 2.4.0
45 BuildRequires: glib2-devel >= 2.12.0
46 BuildRequires: gmime-devel
47 BuildRequires: libxml2-devel
48 BuildRequires: nss-devel
49 BuildRequires: libtool
50 BuildRequires: intltool
51 BuildRequires: gettext-devel
52 # Use "--with vv" to enable Voice & Video features
53 %if 0%{?_with_vv:1}
54 BuildRequires: libpurple-devel >= 2.8.0
55 BuildRequires: glib2-devel >= 2.28.0
56 BuildRequires: libnice-devel >= 0.1.0
57 BuildRequires: gstreamer-devel
58 %endif
59 # Use "--without telepathy" to disable telepathy
60 %if !0%{?_without_telepathy:1}
61 BuildRequires: telepathy-glib-devel >= 0.18.0
62 BuildRequires: glib2-devel >= 2.28.0
63 %endif
65 # Configurable components
66 # Use "--without kerberos" to disable krb5
67 %if !0%{?_without_kerberos:1}
68 BuildRequires: krb5-devel
69 %endif
71 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
74 %description
75 A third-party plugin for the Pidgin multi-protocol instant messenger.
76 It implements the extended version of SIP/SIMPLE used by various products:
78 * Microsoft Lync Server 2010
79 * Microsoft Office Communications Server (OCS 2007/2007 R2)
80 * Microsoft Live Communications Server (LCS 2003/2005)
81 * Reuters Messaging
83 With this plugin you should be able to replace your Microsoft Office
84 Communicator client with Pidgin.
86 This package provides the icon set for Pidgin.
89 %package -n %{purple_plugin}
90 Summary: Libpurple protocol plugin to connect to MS Office Communicator
91 Group: %{pkg_group}
92 License: GPL-2.0+
93 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
95 %description -n %{purple_plugin}
96 A third-party plugin for the Pidgin multi-protocol instant messenger.
97 It implements the extended version of SIP/SIMPLE used by various products:
99 * Microsoft Lync Server 2010
100 * Microsoft Office Communications Server (OCS 2007/2007 R2)
101 * Microsoft Live Communications Server (LCS 2003/2005)
102 * Reuters Messaging
104 This package provides the protocol plugin for libpurple clients.
107 %if !0%{?_without_telepathy:1}
108 %package -n %{empathy_files}
109 Summary: Telepathy connection manager to connect to MS Office Communicator
110 Group: %{pkg_group}
111 License: GPL-2.0+
112 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
114 %description -n %{empathy_files}
115 A Telepathy connection manager that implements the extended version of
116 SIP/SIMPLE used by various products:
118 * Microsoft Lync Server 2010
119 * Microsoft Office Communications Server (OCS 2007/2007 R2)
120 * Microsoft Live Communications Server (LCS 2003/2005)
121 * Reuters Messaging
123 This package provides the icon set for Empathy.
126 %package -n %{ktp_files}
127 Summary: Telepathy connection manager to connect to MS Office Communicator
128 Group: %{pkg_group}
129 License: GPL-2.0+
130 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
132 %description -n %{ktp_files}
133 A Telepathy connection manager that implements the extended version of
134 SIP/SIMPLE used by various products:
136 * Microsoft Lync Server 2010
137 * Microsoft Office Communications Server (OCS 2007/2007 R2)
138 * Microsoft Live Communications Server (LCS 2003/2005)
139 * Reuters Messaging
141 This package provides the profile for KTP account manager.
144 %package -n %{telepathy_plugin}
145 Summary: Telepathy connection manager to connect to MS Office Communicator
146 Group: %{pkg_group}
147 License: GPL-2.0+
148 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
150 %description -n %{telepathy_plugin}
151 A Telepathy connection manager that implements the extended version of
152 SIP/SIMPLE used by various products:
154 * Microsoft Lync Server 2010
155 * Microsoft Office Communications Server (OCS 2007/2007 R2)
156 * Microsoft Live Communications Server (LCS 2003/2005)
157 * Reuters Messaging
159 This package provides the protocol support for Telepathy clients.
160 %endif
163 %package -n %{common_files}
164 Summary: Common files for SIPE protocol plugins
165 Group: %{pkg_group}
166 License: GPL-2.0+
167 BuildArch: noarch
169 %description -n %{common_files}
170 This package provides common files for the SIPE protocol plugins:
172 * Localisation
175 %prep
176 %if 0%{?_with_git:1}
177 %setup -q -n %{name}-%{git}
178 %else
179 %setup -q
180 %endif
183 %build
184 %if 0%{?_with_git:1}
185 ./autogen.sh
186 %endif
187 %configure \
188 --enable-purple \
189 %if !0%{?_without_telepathy:1}
190 --enable-telepathy
191 %else
192 --disable-telepathy
193 %endif
194 make %{_smp_mflags}
195 make %{_smp_mflags} check
198 %install
199 %makeinstall
200 find %{buildroot} -type f -name "*.la" -delete -print
201 # Pidgin doesn't have 24 or 32 pixel icons
202 rm -f \
203 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
204 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
205 %find_lang %{name}
208 %clean
209 rm -rf %{buildroot}
212 %files -n %{purple_plugin}
213 %defattr(-,root,root,-)
214 %doc AUTHORS ChangeLog COPYING NEWS README TODO
215 %{_libdir}/purple-2/libsipe.so
218 %if !0%{?_without_telepathy:1}
219 %files -n %{empathy_files}
220 %defattr(-,root,root,-)
221 %doc AUTHORS COPYING
222 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
223 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
226 %files -n %{ktp_files}
227 %defattr(-,root,root,-)
228 %doc AUTHORS COPYING
229 %{_datadir}/telepathy/profiles/sipe.profile
232 %files -n %{telepathy_plugin}
233 %defattr(-,root,root,-)
234 %doc AUTHORS ChangeLog COPYING NEWS README TODO
235 %{_datadir}/dbus-1/services/*.sipe.service
236 %{_libexecdir}/telepathy-sipe
237 %endif
240 %files -n %{common_files} -f %{name}.lang
241 %defattr(-,root,root,-)
244 %files
245 %defattr(-,root,root,-)
246 %doc AUTHORS COPYING
247 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
248 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
251 %changelog
252 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
253 - update to 1.14.0
255 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
256 - BR telepathy-glib-devel >= 0.18.0
258 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
259 - BR telepathy-glib-devel >= 0.14.0
261 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
262 - add ktp-accounts-kcm-sipe package
264 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
265 - telepathy now requires glib-2.0 >= 2.22.0
266 - use "--without telepathy" to disable telepathy packages
268 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
269 - add empathy-sipe package
271 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
272 - add telepathy-sipe & sipe-common packages
274 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
275 - update to 1.13.3
277 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
278 - update to 1.13.2
280 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
281 - update to 1.13.1
283 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
284 - update to 1.13.0
286 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
287 - we do support Microsoft Lync Server 2010 now.
289 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
290 - update GPL2 license name
292 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
293 - add BR gmime-devel
295 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
296 - add BR nss-devel
298 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
299 - update to 1.12.0
301 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
302 - add "--with vv" option to enable Voice & Video features
304 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
305 - update to 1.11.2
307 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
308 - update to 1.11.1
310 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
311 - update to 1.11.0
313 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
314 - add (commented out) BR libnice-devel
316 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
317 - update to 1.10.1
319 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
320 - add (commented out) BR nss-devel
322 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
323 - update to 1.10.0
325 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
326 - changed --with/--without options to --enable/--disable
328 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
329 - removed --with-krb5 configure option as it is autodetected now
331 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
332 - add SVG icon
334 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
335 - add BR glib2-devel >= 2.12.0
337 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
338 - add tests to build
340 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
341 - update to 1.9.1
343 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
344 - add BR libxml2-devel
346 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
347 - update to 1.9.0
349 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
350 - increased libpurple build requisite to >= 2.4.0
352 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
353 - sync with RPM SPEC from contrib/OBS
355 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
356 - update package summary & description
358 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
359 - update to 1.8.1
361 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
362 - update to 1.8.0
364 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
365 - autogen.sh no longer runs configure
367 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
368 - add configure parameters for purple and telepathy
370 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
371 - add Epoch: for git packages to avoid update clash with official packages
373 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
374 - update to 1.7.1
376 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
377 - add missing Group: to purple-sipe
379 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
380 - update to 1.7.0
382 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
383 - move non-Pidgin files to new sub-package purple-sipe
385 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
386 - remove directory for emoticon theme icons
388 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
389 - libpurple protocol plugins are located under %{_libdir}/purple-2
391 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
392 - added directory for emoticon theme icons
394 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
395 - update to 1.6.3
397 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
398 - reduce libpurple-devel requirement to >= 2.3.1
400 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
401 - update to 1.6.2
403 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
404 - reduce libpurple-devel requirement to >= 2.4.1
406 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
407 - com_err.h only required for kerberos
409 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
410 - require libpurple-devel >= 2.5.0
412 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
413 - refactor configure parameters
414 - make kerberos configurable
415 - don't hard code prefix for git builds
417 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
418 - removed unnecessary zlib-devel
420 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
421 - fix prefix for git builds
423 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
424 - append -Wno-unused-parameter for GCC <4.4 compilation errors
426 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
427 - remove duplicate GPL2
429 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
430 - use "--with git" to build from git
431 - corrected download URL for release archive
432 - add missing BR gettext-devel
434 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
435 - use default rpmbuild CFLAGS also for git builds
436 - merge with SPEC files created by mricon & jberanek
438 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
439 - initial RPM SPEC example generated