Release 1.15.1 -- Bug Fixes I
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob56a2df8b7dc7f7942b66a1d68507fd32c0b97b14
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20120905gitcc6065b
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.15.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: libpurple-devel >= 2.4.0
45 BuildRequires: glib2-devel >= 2.12.0
46 BuildRequires: gmime-devel
47 BuildRequires: libxml2-devel
48 BuildRequires: nss-devel
49 BuildRequires: libtool
50 BuildRequires: intltool
51 BuildRequires: gettext-devel
52 # Use "--with vv" to enable Voice & Video features
53 %if 0%{?_with_vv:1}
54 BuildRequires: libpurple-devel >= 2.8.0
55 BuildRequires: glib2-devel >= 2.28.0
56 BuildRequires: libnice-devel >= 0.1.0
57 BuildRequires: gstreamer-devel
58 %endif
59 # Use "--without telepathy" to disable telepathy
60 %if !0%{?_without_telepathy:1}
61 BuildRequires: telepathy-glib-devel >= 0.18.0
62 BuildRequires: glib2-devel >= 2.28.0
63 %endif
65 # Configurable components
66 # Use "--without kerberos" to disable krb5
67 %if !0%{?_without_kerberos:1}
68 BuildRequires: krb5-devel
69 %endif
71 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
74 %description
75 A third-party plugin for the Pidgin multi-protocol instant messenger.
76 It implements the extended version of SIP/SIMPLE used by various products:
78 * Microsoft Office 365
79 * Microsoft Business Productivity Online Suite (BPOS)
80 * Microsoft Lync Server
81 * Microsoft Office Communications Server (OCS 2007/2007 R2)
82 * Microsoft Live Communications Server (LCS 2003/2005)
83 * Reuters Messaging
85 With this plugin you should be able to replace your Microsoft Office
86 Communicator client with Pidgin.
88 This package provides the icon set for Pidgin.
91 %package -n %{purple_plugin}
92 Summary: Libpurple protocol plugin to connect to MS Office Communicator
93 Group: %{pkg_group}
94 License: GPL-2.0+
95 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
97 %description -n %{purple_plugin}
98 A third-party plugin for the Pidgin multi-protocol instant messenger.
99 It implements the extended version of SIP/SIMPLE used by various products:
101 * Microsoft Office 365
102 * Microsoft Business Productivity Online Suite (BPOS)
103 * Microsoft Lync Server
104 * Microsoft Office Communications Server (OCS 2007/2007 R2)
105 * Microsoft Live Communications Server (LCS 2003/2005)
106 * Reuters Messaging
108 This package provides the protocol plugin for libpurple clients.
111 %if !0%{?_without_telepathy:1}
112 %package -n %{empathy_files}
113 Summary: Telepathy connection manager to connect to MS Office Communicator
114 Group: %{pkg_group}
115 License: GPL-2.0+
116 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
118 %description -n %{empathy_files}
119 A Telepathy connection manager that implements the extended version of
120 SIP/SIMPLE used by various products:
122 * Microsoft Office 365
123 * Microsoft Business Productivity Online Suite (BPOS)
124 * Microsoft Lync Server
125 * Microsoft Office Communications Server (OCS 2007/2007 R2)
126 * Microsoft Live Communications Server (LCS 2003/2005)
127 * Reuters Messaging
129 This package provides the icon set for Empathy.
132 %package -n %{ktp_files}
133 Summary: Telepathy connection manager to connect to MS Office Communicator
134 Group: %{pkg_group}
135 License: GPL-2.0+
136 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
138 %description -n %{ktp_files}
139 A Telepathy connection manager that implements the extended version of
140 SIP/SIMPLE used by various products:
142 * Microsoft Office 365
143 * Microsoft Business Productivity Online Suite (BPOS)
144 * Microsoft Lync Server
145 * Microsoft Office Communications Server (OCS 2007/2007 R2)
146 * Microsoft Live Communications Server (LCS 2003/2005)
147 * Reuters Messaging
149 This package provides the profile for KTP account manager.
152 %package -n %{telepathy_plugin}
153 Summary: Telepathy connection manager to connect to MS Office Communicator
154 Group: %{pkg_group}
155 License: GPL-2.0+
156 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
158 %description -n %{telepathy_plugin}
159 A Telepathy connection manager that implements the extended version of
160 SIP/SIMPLE used by various products:
162 * Microsoft Office 365
163 * Microsoft Business Productivity Online Suite (BPOS)
164 * Microsoft Lync Server
165 * Microsoft Office Communications Server (OCS 2007/2007 R2)
166 * Microsoft Live Communications Server (LCS 2003/2005)
167 * Reuters Messaging
169 This package provides the protocol support for Telepathy clients.
170 %endif
173 %package -n %{common_files}
174 Summary: Common files for SIPE protocol plugins
175 Group: %{pkg_group}
176 License: GPL-2.0+
177 BuildArch: noarch
179 %description -n %{common_files}
180 This package provides common files for the SIPE protocol plugins:
182 * Localisation
185 %prep
186 %if 0%{?_with_git:1}
187 %setup -q -n %{name}-%{git}
188 %else
189 %setup -q
190 %endif
193 %build
194 %if 0%{?_with_git:1}
195 ./autogen.sh
196 %endif
197 %configure \
198 --enable-purple \
199 %if !0%{?_without_telepathy:1}
200 --enable-telepathy
201 %else
202 --disable-telepathy
203 %endif
204 make %{_smp_mflags}
205 make %{_smp_mflags} check
208 %install
209 %makeinstall
210 find %{buildroot} -type f -name "*.la" -delete -print
211 # Pidgin doesn't have 24 or 32 pixel icons
212 rm -f \
213 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
214 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
215 %find_lang %{name}
218 %clean
219 rm -rf %{buildroot}
222 %files -n %{purple_plugin}
223 %defattr(-,root,root,-)
224 %doc AUTHORS ChangeLog COPYING NEWS README TODO
225 %{_libdir}/purple-2/libsipe.so
228 %if !0%{?_without_telepathy:1}
229 %files -n %{empathy_files}
230 %defattr(-,root,root,-)
231 %doc AUTHORS COPYING
232 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
233 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
236 %files -n %{ktp_files}
237 %defattr(-,root,root,-)
238 %doc AUTHORS COPYING
239 %{_datadir}/telepathy/profiles/sipe.profile
242 %files -n %{telepathy_plugin}
243 %defattr(-,root,root,-)
244 %doc AUTHORS ChangeLog COPYING NEWS README TODO
245 %{_datadir}/dbus-1/services/*.sipe.service
246 %{_libexecdir}/telepathy-sipe
247 %endif
250 %files -n %{common_files} -f %{name}.lang
251 %defattr(-,root,root,-)
254 %files
255 %defattr(-,root,root,-)
256 %doc AUTHORS COPYING
257 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
258 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
261 %changelog
262 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
263 - update to 1.15.1
265 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
266 - update package description texts
268 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
269 - update to 1.15.0
271 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
272 - update to 1.14.1
274 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
275 - update to 1.14.0
277 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
278 - BR telepathy-glib-devel >= 0.18.0
280 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
281 - BR telepathy-glib-devel >= 0.14.0
283 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
284 - add ktp-accounts-kcm-sipe package
286 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
287 - telepathy now requires glib-2.0 >= 2.22.0
288 - use "--without telepathy" to disable telepathy packages
290 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
291 - add empathy-sipe package
293 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
294 - add telepathy-sipe & sipe-common packages
296 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
297 - update to 1.13.3
299 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
300 - update to 1.13.2
302 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
303 - update to 1.13.1
305 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
306 - update to 1.13.0
308 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
309 - we do support Microsoft Lync Server 2010 now.
311 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
312 - update GPL2 license name
314 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
315 - add BR gmime-devel
317 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
318 - add BR nss-devel
320 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
321 - update to 1.12.0
323 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
324 - add "--with vv" option to enable Voice & Video features
326 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
327 - update to 1.11.2
329 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
330 - update to 1.11.1
332 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
333 - update to 1.11.0
335 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
336 - add (commented out) BR libnice-devel
338 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
339 - update to 1.10.1
341 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
342 - add (commented out) BR nss-devel
344 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
345 - update to 1.10.0
347 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
348 - changed --with/--without options to --enable/--disable
350 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
351 - removed --with-krb5 configure option as it is autodetected now
353 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
354 - add SVG icon
356 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
357 - add BR glib2-devel >= 2.12.0
359 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
360 - add tests to build
362 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
363 - update to 1.9.1
365 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
366 - add BR libxml2-devel
368 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
369 - update to 1.9.0
371 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
372 - increased libpurple build requisite to >= 2.4.0
374 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
375 - sync with RPM SPEC from contrib/OBS
377 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
378 - update package summary & description
380 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
381 - update to 1.8.1
383 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
384 - update to 1.8.0
386 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
387 - autogen.sh no longer runs configure
389 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
390 - add configure parameters for purple and telepathy
392 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
393 - add Epoch: for git packages to avoid update clash with official packages
395 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
396 - update to 1.7.1
398 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
399 - add missing Group: to purple-sipe
401 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
402 - update to 1.7.0
404 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
405 - move non-Pidgin files to new sub-package purple-sipe
407 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
408 - remove directory for emoticon theme icons
410 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
411 - libpurple protocol plugins are located under %{_libdir}/purple-2
413 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
414 - added directory for emoticon theme icons
416 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
417 - update to 1.6.3
419 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
420 - reduce libpurple-devel requirement to >= 2.3.1
422 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
423 - update to 1.6.2
425 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
426 - reduce libpurple-devel requirement to >= 2.4.1
428 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
429 - com_err.h only required for kerberos
431 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
432 - require libpurple-devel >= 2.5.0
434 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
435 - refactor configure parameters
436 - make kerberos configurable
437 - don't hard code prefix for git builds
439 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
440 - removed unnecessary zlib-devel
442 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
443 - fix prefix for git builds
445 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
446 - append -Wno-unused-parameter for GCC <4.4 compilation errors
448 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
449 - remove duplicate GPL2
451 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
452 - use "--with git" to build from git
453 - corrected download URL for release archive
454 - add missing BR gettext-devel
456 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
457 - use default rpmbuild CFLAGS also for git builds
458 - merge with SPEC files created by mricon & jberanek
460 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
461 - initial RPM SPEC example generated