update files in preparation for next release
[siplcs.git] / contrib / opensuse-build-service / pidgin-sipe.spec
blobe9b45d4ab4d4b676b06c1a415ca0d20b7d0db0de
2 # OBS SPEC file to generate a RPM for pidgin-sipe.
4 # It has support for:
6 # RedHat family (CentOS, Fedora, RHEL)
7 # Mandriva
8 # SUSE family (openSUSE, SLED, SLES)
9 # Windows (mingw32, mingw64)
12 # Build options
13 %undefine build_telepathy
15 # Check for mingw32 cross compilation build
17 # Manually add this repository to your private OBS project:
19 # <repository name="mingw32">
20 # <path repository="openSUSE_11.4" project="windows:mingw:win32"/>
21 # <arch>i586</arch>
22 # </repository>
24 %if "%{_repository}" == "mingw32"
25 %define purple_sipe_mingw32 1
26 %define mingw_prefix mingw32-
27 %define mingw_cache %{_mingw32_cache}
28 %define mingw_configure %{_mingw32_configure}
29 %define mingw_datadir %{_mingw32_datadir}
30 %define mingw_debug_package %{_mingw32_debug_package}
31 %define mingw_ldflags MINGW32_LDFLAGS
32 %define mingw_libdir %{_mingw32_libdir}
33 %define mingw_make %{_mingw32_make}
34 %define mingw_makeinstall %{_mingw32_makeinstall}
35 %define __strip %{_mingw32_strip}
36 %define __objdump %{_mingw32_objdump}
37 %define _use_internal_dependency_generator 0
38 %define __find_requires %{_mingw32_findrequires}
39 %define __find_provides %{_mingw32_findprovides}
40 %define __os_install_post %{_mingw32_debug_install_post} \
41 %{_mingw32_install_post}
42 %endif
44 # Check for mingw64 cross compilation build
46 # Manually add this repository to your private OBS project:
48 # <repository name="mingw64">
49 # <path repository="openSUSE_11.4" project="windows:mingw:win64"/>
50 # <arch>i586</arch>
51 # </repository>
53 %if "%{_repository}" == "mingw64"
54 %define purple_sipe_mingw64 1
55 %define mingw_prefix mingw64-
56 %define mingw_cache %{_mingw64_cache}
57 %define mingw_configure %{_mingw64_configure}
58 %define mingw_datadir %{_mingw64_datadir}
59 %define mingw_debug_package %{_mingw64_debug_package}
60 %define mingw_ldflags MINGW64_LDFLAGS
61 %define mingw_libdir %{_mingw64_libdir}
62 %define mingw_make %{_mingw64_make}
63 %define mingw_makeinstall %{_mingw64_makeinstall}
64 %define __strip %{_mingw64_strip}
65 %define __objdump %{_mingw64_objdump}
66 %define _use_internal_dependency_generator 0
67 %define __find_requires %{_mingw64_findrequires}
68 %define __find_provides %{_mingw64_findprovides}
69 %define __os_install_post %{_mingw64_debug_install_post} \
70 %{_mingw64_install_post}
71 %endif
73 %define purple_plugin %{?mingw_prefix:%{mingw_prefix}}libpurple-plugin-sipe
74 %define telepathy_plugin %{?mingw_prefix:%{mingw_prefix}}telepathy-plugin-sipe
75 %define nsis_package %{?mingw_prefix:%{mingw_prefix}}pidgin-sipe-nsis
76 %define common_files sipe-common
77 %define empathy_files empathy-sipe
78 %define ktp_files ktp-accounts-kcm-sipe
81 %define purple_develname libpurple-devel
83 %if 0%{?mdkversion} >= 200910
84 %ifarch x86_64
85 %define purple_develname lib64purple-devel
86 %endif
87 %if 0%{?mdkversion} >= 201000
88 %ifnarch x86_64
89 %define has_libnice 1
90 %endif
91 %endif
92 %endif
94 %if 0%{?suse_version}
95 %define nss_develname mozilla-nss-devel
96 %if 0%{?suse_version} >= 1120
97 %define has_libnice 1
98 %if 0%{?suse_version} > 1140
99 %define has_gstreamer 1
100 %if 0%{?suse_version} > 1210
101 %define build_telepathy 1
102 %define nice_gstreamer gstreamer-0_10-libnice
103 %endif
104 %endif
105 %endif
106 %else
107 %define nss_develname nss-devel
108 %endif
110 %if 0%{?suse_version} || 0%{?sles_version}
111 %define pkg_group Productivity/Networking/Instant Messenger
112 %endif
113 %if 0%{?fedora}
114 %define pkg_group Applications/Internet
115 %if 0%{?fedora} >= 11
116 %define has_libnice 1
117 %if 0%{?fedora} >= 15
118 %define has_gstreamer 1
119 %if 0%{?fedora} >= 17
120 %define build_telepathy 1
121 %define build_ktp 1
122 %if 0%{?fedora} >= 20
123 %define nice_gstreamer libnice-gstreamer
124 %endif
125 %endif
126 %endif
127 %endif
128 %endif
129 %if 0%{?mdkversion}
130 %define pkg_group Networking/Instant messaging
131 %else
132 %define pkg_group Applications/Internet
133 %endif
135 %if 0%{?purple_sipe_mingw32}
136 Name: mingw32-pidgin-sipe
137 %else
138 %if 0%{?purple_sipe_mingw64}
139 Name: mingw64-pidgin-sipe
140 %else
141 Name: pidgin-sipe
142 %endif
143 %endif
144 Summary: Pidgin protocol plugin to connect to MS Office Communicator
145 Version: 1.18.1
146 Release: 1
147 Source: pidgin-sipe-%{version}.tar.gz
148 Group: %{pkg_group}
149 License: GPL-2.0+
150 URL: http://sipe.sourceforge.net/
152 BuildRoot: %{_tmppath}/%{name}-%{version}-build
154 %if 0%{?mingw_prefix:1}
156 # Windows cross-compilation build setup
158 BuildArch: noarch
159 #!BuildIgnore: post-build-checks
161 BuildRequires: %{mingw_prefix}filesystem >= 23
162 BuildRequires: %{mingw_prefix}cross-gcc
163 BuildRequires: %{mingw_prefix}cross-binutils
164 BuildRequires: %{mingw_prefix}gettext-runtime
165 BuildRequires: %{mingw_prefix}cross-pkg-config
166 BuildRequires: %{mingw_prefix}glib2-devel >= 2.12.0
167 BuildRequires: %{mingw_prefix}libxml2-devel
168 BuildRequires: %{mingw_prefix}mozilla-nss-devel
169 BuildRequires: %{mingw_prefix}libpurple-devel >= 2.4.0
170 BuildRequires: %{mingw_prefix}cross-nsis
172 # For directory ownership
173 BuildRequires: %{mingw_prefix}pidgin
175 # Make sure telepathy is disabled for Windows builds
176 %undefine build_telepathy
178 %else
180 # Standard Linux build setup
182 BuildRequires: %{purple_develname} >= 2.4.0
183 BuildRequires: libxml2-devel
184 BuildRequires: %{nss_develname}
185 BuildRequires: gettext-devel
186 # The following two are required to enable Voice & Video features
187 %if 0%{?has_libnice:1}
188 BuildRequires: libnice-devel
189 %if 0%{?nice_gstreamer:1}
190 # Dependency required when gstreamer support is split into two packages
191 Requires: %{nice_gstreamer}
192 %endif
193 %endif
194 %if 0%{?has_gstreamer:1}
195 BuildRequires: pkgconfig(gstreamer-0.10)
196 %endif
197 # Requirements for telepathy backend
198 %if 0%{?build_telepathy:1}
199 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
200 BuildRequires: gmime-devel
201 BuildRequires: glib2-devel >= 2.28.0
202 %endif
204 # Configurable components
205 %if !0%{?_without_kerberos:1}
206 BuildRequires: krb5-devel
207 %endif
209 # For directory ownership
210 BuildRequires: pidgin
211 %if 0%{?build_telepathy:1}
212 BuildRequires: empathy
213 %endif
214 Requires: pidgin
215 %if 0%{?sles_version} == 10
216 BuildRequires: gnome-keyring-devel
217 %endif
219 # For OBS's "have choice for" for Fedora 11 (only)
220 %if 0%{?fedora_version} == 11
221 BuildRequires: libproxy-mozjs
222 BuildRequires: PolicyKit-gnome
223 %endif
225 # For OBS's "have choice for" for Mandriva 2010.1 (and up?)
226 %if 0%{?mdkversion} >= 201010
227 BuildRequires: polkit-gnome
228 %endif
230 # For OBS's "have choice for" for Mandriva 2011 (and up?)
231 %if 0%{?mdkversion} >= 201100
232 BuildRequires: packagekit-gstreamer-plugin
233 BuildRequires: gnome-packagekit-common
234 %endif
236 # End Windows cross-compilation/Linux build setup
237 %endif
239 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
240 BuildRequires: libtool
241 BuildRequires: intltool
242 BuildRequires: glib2-devel >= 2.12.0
245 %description
246 A third-party plugin for the Pidgin multi-protocol instant messenger.
247 It implements the extended version of SIP/SIMPLE used by various products:
249 * Microsoft Office 365
250 * Microsoft Business Productivity Online Suite (BPOS)
251 * Microsoft Lync Server
252 * Microsoft Office Communications Server (OCS 2007/2007 R2)
253 * Microsoft Live Communications Server (LCS 2003/2005)
254 * Reuters Messaging
256 With this plugin you should be able to replace your Microsoft Office
257 Communicator client with Pidgin.
259 This package provides the icon set for Pidgin.
262 %package -n %{purple_plugin}
263 Summary: Libpurple protocol plugin to connect to MS Office Communicator
264 Group: %{pkg_group}
265 License: GPL-2.0+
266 Obsoletes: purple-sipe
267 %if 0%{?build_telepathy:1}
268 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
269 %endif
271 %description -n %{purple_plugin}
272 A third-party plugin for the Pidgin multi-protocol instant messenger.
273 It implements the extended version of SIP/SIMPLE used by various products:
275 * Microsoft Office 365
276 * Microsoft Business Productivity Online Suite (BPOS)
277 * Microsoft Lync Server
278 * Microsoft Office Communications Server (OCS 2007/2007 R2)
279 * Microsoft Live Communications Server (LCS 2003/2005)
280 * Reuters Messaging
282 This package provides the protocol plugin for libpurple clients.
285 %if 0%{?build_telepathy:1}
286 %package -n %{empathy_files}
287 Summary: Telepathy connection manager to connect to MS Office Communicator
288 Group: %{pkg_group}
289 License: GPL-2.0+
290 Requires: empathy
291 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
293 %description -n %{empathy_files}
294 A Telepathy connection manager that implements the extended version of
295 SIP/SIMPLE used by various products:
297 * Microsoft Office 365
298 * Microsoft Business Productivity Online Suite (BPOS)
299 * Microsoft Lync Server
300 * Microsoft Office Communications Server (OCS 2007/2007 R2)
301 * Microsoft Live Communications Server (LCS 2003/2005)
302 * Reuters Messaging
304 This package provides the icon set for Empathy.
307 %if 0%{?build_ktp:1}
308 %package -n %{ktp_files}
309 Summary: Telepathy connection manager to connect to MS Office Communicator
310 Group: %{pkg_group}
311 License: GPL-2.0+
312 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
314 %description -n %{ktp_files}
315 A Telepathy connection manager that implements the extended version of
316 SIP/SIMPLE used by various products:
318 * Microsoft Office 365
319 * Microsoft Business Productivity Online Suite (BPOS)
320 * Microsoft Lync Server
321 * Microsoft Office Communications Server (OCS 2007/2007 R2)
322 * Microsoft Live Communications Server (LCS 2003/2005)
323 * Reuters Messaging
325 This package provides the profile for KTP account manager.
326 %endif
329 %package -n %{telepathy_plugin}
330 Summary: Telepathy connection manager to connect to MS Office Communicator
331 Group: %{pkg_group}
332 License: GPL-2.0+
333 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
335 %description -n %{telepathy_plugin}
336 A Telepathy connection manager that implements the extended version of
337 SIP/SIMPLE used by various products:
339 * Microsoft Office 365
340 * Microsoft Business Productivity Online Suite (BPOS)
341 * Microsoft Lync Server
342 * Microsoft Office Communications Server (OCS 2007/2007 R2)
343 * Microsoft Live Communications Server (LCS 2003/2005)
344 * Reuters Messaging
346 This package provides the protocol support for Telepathy clients.
349 %package -n %{common_files}
350 Summary: Common files for SIPE protocol plugins
351 Group: %{pkg_group}
352 License: GPL-2.0+
353 BuildArch: noarch
355 %description -n %{common_files}
356 This package provides common files for the SIPE protocol plugins:
358 * Localisation
359 %endif
362 %if 0%{?mingw_prefix:1}
363 %package -n %{nsis_package}
364 Summary: Windows Pidgin protocol plugin to connect to MS Office Communicator
365 Group: %{pkg_group}
366 License: GPL-2.0+
368 %description -n %{nsis_package}
369 A third-party plugin for the Pidgin multi-protocol instant messenger.
370 It implements the extended version of SIP/SIMPLE used by various products:
372 * Microsoft Office 365
373 * Microsoft Business Productivity Online Suite (BPOS)
374 * Microsoft Lync Server
375 * Microsoft Office Communications Server (OCS 2007/2007 R2)
376 * Microsoft Live Communications Server (LCS 2003/2005)
377 * Reuters Messaging
379 This package contains the NSIS installer package of the protocol plugin
380 for Pidgin on Windows.
381 %endif
384 %{mingw_debug_package}
387 %prep
388 %setup -q -n pidgin-sipe-%{version}
390 %build
391 %if 0%{?mingw_prefix:1}
393 # Windows cross-compilation build
395 %{?env_options}
396 echo "lt_cv_deplibs_check_method='pass_all'" >>%{mingw_cache}
397 autoreconf --verbose --install --force
398 %{mingw_ldflags}="-Wl,--exclude-libs=libintl.a -Wl,--exclude-libs=libiconv.a -lws2_32"
399 %{mingw_configure} \
400 --enable-purple \
401 %if 0%{?build_telepathy:1}
402 --enable-telepathy
403 %else
404 --disable-telepathy
405 %endif
406 %{mingw_make} %{_smp_mflags} || %{mingw_make}
408 %else
410 # Standard Linux build
412 %if 0%{?sles_version} == 10
413 export CFLAGS="%optflags -I%{_includedir}/gssapi"
414 %endif
415 %if 0%{?mdkversion}
416 autoreconf --verbose --install --force
417 %endif
418 %configure \
419 --enable-purple \
420 %if 0%{?build_telepathy:1}
421 --enable-telepathy
422 %else
423 --disable-telepathy
424 %endif
425 make %{_smp_mflags}
426 make %{_smp_mflags} check
428 # End Windows cross-compilation/Linux build setup
429 %endif
432 %install
433 %if 0%{?mingw_prefix:1}
435 # Windows cross-compilation install
437 %{mingw_makeinstall}
438 rm -f %{buildroot}%{mingw_libdir}/purple-2/*.dll.a
440 # generate NSIS installer package
441 perl contrib/opensuse-build-service/generate_nsi.pl po/LINGUAS \
442 <contrib/opensuse-build-service/pidgin-sipe.nsi.template \
443 >%{buildroot}/pidgin-sipe.nsi
445 set -e; \
446 cd %{buildroot}; \
447 makensis \
448 -DVERSION=%{version} \
449 -DMINGW_LIBDIR=%{buildroot}%{mingw_libdir} \
450 -DMINGW_DATADIR=%{buildroot}%{mingw_datadir} \
451 pidgin-sipe.nsi \
453 rm -f %{buildroot}/pidgin-sipe.nsi
455 %else
457 # Standard Linux install
459 %makeinstall
461 # End Windows cross-compilation/Linux build setup
462 %endif
464 find %{buildroot} -type f -name "*.la" -delete -print
465 # SLES11 defines suse_version = 1110
466 %if 0%{?suse_version} && 0%{?suse_version} < 1120
467 rm -r %{buildroot}/%{_datadir}/pixmaps/pidgin/protocols/scalable
468 %endif
469 # Pidgin doesn't have 24 or 32 pixel icons
470 rm -f \
471 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
472 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
473 %if 0%{?build_telepathy:1}
474 %if !0%{?build_ktp:1}
475 rm -r %{buildroot}%{_datadir}/telepathy
476 %endif
477 %endif
478 %find_lang pidgin-sipe
481 %clean
482 rm -rf %{buildroot}
485 %if 0%{?build_telepathy:1}
486 %files -n %{purple_plugin}
487 %else
488 %files -n %{purple_plugin} -f pidgin-sipe.lang
489 %endif
490 %defattr(-,root,root,-)
491 %doc AUTHORS ChangeLog COPYING NEWS README TODO
492 %if 0%{?mingw_prefix:1}
493 %{mingw_libdir}/purple-2/libsipe.dll
494 %else
495 %{_libdir}/purple-2/libsipe.so
496 %endif
499 %if 0%{?build_telepathy:1}
500 %files -n %{empathy_files}
501 %defattr(-,root,root,-)
502 %doc AUTHORS COPYING
503 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
504 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
507 %if 0%{?build_ktp:1}
508 %files -n %{ktp_files}
509 %defattr(-,root,root,-)
510 %doc AUTHORS COPYING
511 %{_datadir}/telepathy/profiles/sipe.profile
512 %endif
515 %files -n %{telepathy_plugin}
516 %defattr(-,root,root,-)
517 %doc AUTHORS ChangeLog COPYING NEWS README TODO
518 %{_datadir}/dbus-1/services/*.sipe.service
519 %{_libexecdir}/telepathy-sipe
522 %files -n %{common_files} -f pidgin-sipe.lang
523 %defattr(-,root,root,-)
524 %endif
527 %files
528 %defattr(-,root,root,-)
529 %doc AUTHORS COPYING
530 %if 0%{?mingw_prefix:1}
531 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.png
532 %{mingw_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
533 %else
534 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
535 # SLES11 defines suse_version = 1110
536 %if !0%{?suse_version} || 0%{?suse_version} >= 1120
537 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
538 %endif
539 %endif
542 %if 0%{?mingw_prefix:1}
543 %files -n %{nsis_package}
544 %defattr(-, root, root)
545 /pidgin-sipe-%{version}.exe
546 %endif
549 %changelog
550 * DDD MMM DD 2014 J. D. User <jduser@noreply.com> 1.18.1
551 - update to 1.18.1
553 * Sat Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
554 - F20+/openSUSE 12.2+ require libnice gstreamer-0.10 plugin
556 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
557 - update to 1.18.0
559 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
560 - update to 1.17.3
562 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
563 - update to 1.17.2
565 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
566 - update to 1.17.1
568 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
569 - update to 1.17.0
571 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
572 - update to 1.16.1
574 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
575 - update to 1.16.0
577 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
578 - update to 1.15.1
580 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
581 - update package description texts
583 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
584 - update to 1.15.0
586 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
587 - update to 1.14.1
589 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
590 - update to 1.14.0
592 * Tue Sep 25 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
593 - change BR gstreamer-devel to pkgconfig(gstreamer-0.10)
595 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
596 - BR telepathy-glib-devel >= 0.18.0
598 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
599 - BR telepathy-glib-devel >= 0.14.0
601 * Sun Sep 02 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
602 - really disable telepathy for Windows cross-compilation builds
604 * Thu Aug 30 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
605 - updates to enable telepathy build
607 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
608 - update to 1.13.3
610 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
611 - update to 1.13.2
613 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
614 - update to 1.13.1
616 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
617 - update to 1.13.0
619 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
620 - we do support Microsoft Lync Server 2010 now.
622 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
623 - update GPL2 license name
625 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
626 - add BR gmime-devel for Fedora to have at least one verification platform
628 * Sun Nov 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
629 - fix Mandriva 2011 unresolvable BR
631 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
632 - add BR nss-devel
634 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
635 - add NSIS package for mingw builds
637 * Sat Oct 01 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
638 - add mingw64 build
640 * Wed Sep 28 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
641 - remove BR mingw32-mozilla-nss-devel, not needed for SSPI.
643 * Mon Sep 19 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
644 - update mingw32 build
645 - update descriptions
647 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
648 - update to 1.12.0
650 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
651 - add gstreamer-devel to enable Voice & Video features
653 * Sat Dec 11 2010 J. D. User <jduser@noreply.com> 1.11.2-*git*
654 - add optional subpackage for telepathy connection manager
656 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
657 - update to 1.11.2
659 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
660 - update to 1.11.1
662 * Fri Oct 15 2010 J. D. User <jduser@noreply.com> 1.11.0-*git*
663 - add mingw32 build configuration
665 * Sun Oct 03 2010 J. D. User <jduser@noreply.com> 1.11.0
666 - update to 1.11.0
668 * Thu Sep 02 2010 J. D. User <jduser@noreply.com> pre-1.11.0-*git*
669 - Mandriva config for OBS has changed
671 * Tue May 04 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
672 - add libnice build information discovered through OBS testing
674 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
675 - add NSS build information discovered through OBS testing
677 * Wed Apr 04 2010 pier11 <pier11@operamail.com> 1.10.0
678 - release
680 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
681 - Mandriva has too old libtool version
683 * Fri Apr 02 2010 J. D. User <jduser@noreply.com> pre-1.10.0-*git*
684 - SLE11, openSUSE 11.0/1 don't have pidgin/protocols/scalable directory
686 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.10.0-*git*
687 - OBS tests of pre-1.10.0 git-snapshot 4fa20cd65e5be0e469d4aa55d861f11c5b08b816
689 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
690 - added --enable/--disable build options
692 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
693 - removed --with-krb5 configure option as it is autodetected now
695 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
696 - add SVG icon
698 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
699 - add BR glib2-devel >= 2.12.0
701 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
702 - add tests to build
704 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
705 - update to 1.9.1
707 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
708 - add BR libxml2-devel
710 * Wed Mar 10 2010 pier11 <pier11@operamail.com> 1.9.0
711 - release
712 - dropped SLE 10 due to libpurple min version increase
713 - updated target distros in comment line
715 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
716 - increased libpurple build requisite to >= 2.4.0
718 * Sun Mar 07 2010 pier11 <pier11@operamail.com> pre-1.9.0-*git*
719 - OBS tests of pre-1.9.0 git-snapshot 61ea0856855483b9e18f23a87afe47437e526f0e
721 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
722 - sync with RPM SPEC from contrib/rpm
724 * Sun Feb 08 2010 pier11 <pier11@operamail.com> 1.8.0
725 - source is an original 1.8.0 with patch: git(upstream) 9c34cc3557daa3d61a002002492c71d0343c8cae
726 - temp hack - renamed source in spec from .bz2 to .gz as the latter was prepared with the patch.
728 * Sun Nov 22 2009 pier11 <pier11@operamail.com> 1.7.1
729 - reinstated enable-quality-check
731 * Wed Nov 04 2009 John Beranek <john@redux.org.uk> 1.7.0
732 - Spec file modifications to allow SLES/D 10 and Mandriva 2009.1 builds
734 * Tue Nov 03 2009 John Beranek <john@redux.org.uk> 1.7.0
735 - Spec file modifications for openSUSE build service
737 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
738 - move non-Pidgin files to new sub-package purple-sipe
740 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
741 - remove directory for emoticon theme icons
743 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
744 - libpurple protocol plugins are located under %%{_libdir}/purple-2
746 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
747 - added directory for emoticon theme icons
749 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
750 - update to 1.6.3
752 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
753 - reduce libpurple-devel requirement to >= 2.3.1
755 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
756 - update to 1.6.2
758 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
759 - reduce libpurple-devel requirement to >= 2.4.1
761 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
762 - com_err.h only required for kerberos
764 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
765 - require libpurple-devel >= 2.5.0
767 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
768 - refactor configure parameters
769 - make kerberos configurable
770 - don't hard code prefix for git builds
772 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
773 - removed unnecessary zlib-devel
775 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
776 - fix prefix for git builds
778 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
779 - append -Wno-unused-parameter for GCC <4.4 compilation errors
781 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
782 - remove duplicate GPL2
784 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
785 - use "--with git" to build from git
786 - corrected download URL for release archive
787 - add missing BR gettext-devel
789 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
790 - use default rpmbuild CFLAGS also for git builds
791 - merge with SPEC files created by mricon & jberanek
793 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
794 - initial RPM SPEC example generated