Release 1.18.1 -- Bug Fixes I
[siplcs.git] / contrib / rpm / pidgin-sipe.spec
blob9181c521cb1aec0c010acc218db212cf45447a77
2 # Example SPEC file to generate a RPM for pidgin-sipe.
3 # It should work out-of-the-box on Fedora 10+ or RHEL5+.
5 %if 0%{?_with_git:1}
6 #------------------------------- BUILD FROM GIT -------------------------------
7 # Add "--with git" to the rpmbuild command line to build from git
9 # Instructions how to access the repository: http://sipe.sourceforge.net/git/
11 # Run "./git-snapshot.sh ." in your local repository.
12 # Then update the following line from the generated archive name
13 %define git 20140308git949b574
14 # Increment when you generate several RPMs on the same day...
15 %define gitcount 0
16 #------------------------------- BUILD FROM GIT -------------------------------
17 %endif
19 %define purple_plugin purple-sipe
20 %define telepathy_plugin telepathy-sipe
21 %define common_files sipe-common
22 %define empathy_files empathy-sipe
23 %define ktp_files ktp-accounts-kcm-sipe
24 %define pkg_group Applications/Internet
26 Name: pidgin-sipe
27 Summary: Pidgin protocol plugin to connect to MS Office Communicator
28 Version: 1.18.1
29 %if 0%{?_with_git:1}
30 Release: %{gitcount}.%{git}%{?dist}
31 Source: %{name}-%{git}.tar.bz2
32 # git package overrides official released package
33 Epoch: 1
34 %else
35 Release: 1%{?dist}
36 Source: http://downloads.sourceforge.net/sipe/%{name}-%{version}.tar.bz2
37 %endif
38 Group: %{pkg_group}
39 License: GPL-2.0+
40 URL: http://sipe.sourceforge.net/
42 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
44 BuildRequires: pkgconfig(purple) >= 2.4.0
45 BuildRequires: pkgconfig(glib-2.0) >= 2.12.0
46 BuildRequires: pkgconfig(gmodule-2.0) >= 2.12.0
47 BuildRequires: gmime-devel
48 BuildRequires: pkgconfig(libxml-2.0)
49 BuildRequires: pkgconfig(nss)
50 BuildRequires: libtool
51 BuildRequires: intltool
52 BuildRequires: gettext-devel
53 # Use "--with vv" to enable Voice & Video features
54 %if 0%{?_with_vv:1}
55 BuildRequires: pkgconfig(purple) >= 2.8.0
56 BuildRequires: pkgconfig(nice) >= 0.1.0
57 %if 0%{?fedora} >= 20
58 # Dependency required when gstreamer support is split into two packages
59 Requires: libnice-gstreamer
60 %endif
61 BuildRequires: pkgconfig(gstreamer-0.10)
62 %endif
63 # Use "--without telepathy" to disable telepathy
64 %if !0%{?_without_telepathy:1}
65 BuildRequires: pkgconfig(telepathy-glib) >= 0.18.0
66 BuildRequires: pkgconfig(glib-2.0) >= 2.28.0
67 BuildRequires: pkgconfig(gio-2.0) >= 2.32.0
68 BuildRequires: pkgconfig(gobject-2.0)
69 BuildRequires: pkgconfig(dbus-glib-1)
70 %endif
72 # Configurable components
73 # Use "--without kerberos" to disable krb5
74 %if !0%{?_without_kerberos:1}
75 BuildRequires: krb5-devel
76 %endif
78 Requires: %{purple_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
81 %description
82 A third-party plugin for the Pidgin multi-protocol instant messenger.
83 It implements the extended version of SIP/SIMPLE used by various products:
85 * Microsoft Office 365
86 * Microsoft Business Productivity Online Suite (BPOS)
87 * Microsoft Lync Server
88 * Microsoft Office Communications Server (OCS 2007/2007 R2)
89 * Microsoft Live Communications Server (LCS 2003/2005)
90 * Reuters Messaging
92 With this plugin you should be able to replace your Microsoft Office
93 Communicator client with Pidgin.
95 This package provides the icon set for Pidgin.
98 %package -n %{purple_plugin}
99 Summary: Libpurple protocol plugin to connect to MS Office Communicator
100 Group: %{pkg_group}
101 License: GPL-2.0+
102 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
104 %description -n %{purple_plugin}
105 A third-party plugin for the Pidgin multi-protocol instant messenger.
106 It implements the extended version of SIP/SIMPLE used by various products:
108 * Microsoft Office 365
109 * Microsoft Business Productivity Online Suite (BPOS)
110 * Microsoft Lync Server
111 * Microsoft Office Communications Server (OCS 2007/2007 R2)
112 * Microsoft Live Communications Server (LCS 2003/2005)
113 * Reuters Messaging
115 This package provides the protocol plugin for libpurple clients.
118 %if !0%{?_without_telepathy:1}
119 %package -n %{empathy_files}
120 Summary: Telepathy connection manager to connect to MS Office Communicator
121 Group: %{pkg_group}
122 License: GPL-2.0+
123 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
125 %description -n %{empathy_files}
126 A Telepathy connection manager that implements the extended version of
127 SIP/SIMPLE used by various products:
129 * Microsoft Office 365
130 * Microsoft Business Productivity Online Suite (BPOS)
131 * Microsoft Lync Server
132 * Microsoft Office Communications Server (OCS 2007/2007 R2)
133 * Microsoft Live Communications Server (LCS 2003/2005)
134 * Reuters Messaging
136 This package provides the icon set for Empathy.
139 %package -n %{ktp_files}
140 Summary: Telepathy connection manager to connect to MS Office Communicator
141 Group: %{pkg_group}
142 License: GPL-2.0+
143 Requires: %{telepathy_plugin} = %{?epoch:%{epoch}:}%{version}-%{release}
145 %description -n %{ktp_files}
146 A Telepathy connection manager that implements the extended version of
147 SIP/SIMPLE used by various products:
149 * Microsoft Office 365
150 * Microsoft Business Productivity Online Suite (BPOS)
151 * Microsoft Lync Server
152 * Microsoft Office Communications Server (OCS 2007/2007 R2)
153 * Microsoft Live Communications Server (LCS 2003/2005)
154 * Reuters Messaging
156 This package provides the profile for KTP account manager.
159 %package -n %{telepathy_plugin}
160 Summary: Telepathy connection manager to connect to MS Office Communicator
161 Group: %{pkg_group}
162 License: GPL-2.0+
163 Requires: %{common_files} = %{?epoch:%{epoch}:}%{version}-%{release}
165 %description -n %{telepathy_plugin}
166 A Telepathy connection manager that implements the extended version of
167 SIP/SIMPLE used by various products:
169 * Microsoft Office 365
170 * Microsoft Business Productivity Online Suite (BPOS)
171 * Microsoft Lync Server
172 * Microsoft Office Communications Server (OCS 2007/2007 R2)
173 * Microsoft Live Communications Server (LCS 2003/2005)
174 * Reuters Messaging
176 This package provides the protocol support for Telepathy clients.
177 %endif
180 %package -n %{common_files}
181 Summary: Common files for SIPE protocol plugins
182 Group: %{pkg_group}
183 License: GPL-2.0+
184 BuildArch: noarch
186 %description -n %{common_files}
187 This package provides common files for the SIPE protocol plugins:
189 * Localisation
192 %prep
193 %if 0%{?_with_git:1}
194 %setup -q -n %{name}-%{git}
195 %else
196 %setup -q
197 %endif
200 %build
201 %if 0%{?_with_git:1}
202 ./autogen.sh
203 %endif
204 %configure \
205 --enable-purple \
206 %if !0%{?_without_telepathy:1}
207 --enable-telepathy
208 %else
209 --disable-telepathy
210 %endif
211 make %{_smp_mflags}
212 make %{_smp_mflags} check
215 %install
216 %makeinstall
217 find %{buildroot} -type f -name "*.la" -delete -print
218 # Pidgin doesn't have 24 or 32 pixel icons
219 rm -f \
220 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/24/sipe.png \
221 %{buildroot}%{_datadir}/pixmaps/pidgin/protocols/32/sipe.png
222 %find_lang %{name}
225 %clean
226 rm -rf %{buildroot}
229 %files -n %{purple_plugin}
230 %defattr(-,root,root,-)
231 %doc AUTHORS ChangeLog COPYING NEWS README TODO
232 %{_libdir}/purple-2/libsipe.so
235 %if !0%{?_without_telepathy:1}
236 %files -n %{empathy_files}
237 %defattr(-,root,root,-)
238 %doc AUTHORS COPYING
239 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.png
240 %{_datadir}/empathy/icons/hicolor/*/apps/im-sipe.svg
243 %files -n %{ktp_files}
244 %defattr(-,root,root,-)
245 %doc AUTHORS COPYING
246 %{_datadir}/telepathy/profiles/sipe.profile
249 %files -n %{telepathy_plugin}
250 %defattr(-,root,root,-)
251 %doc AUTHORS ChangeLog COPYING NEWS README TODO
252 %{_datadir}/dbus-1/services/*.sipe.service
253 %{_libexecdir}/telepathy-sipe
254 %endif
257 %files -n %{common_files} -f %{name}.lang
258 %defattr(-,root,root,-)
261 %files
262 %defattr(-,root,root,-)
263 %doc AUTHORS COPYING
264 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.png
265 %{_datadir}/pixmaps/pidgin/protocols/*/sipe.svg
268 %changelog
269 * Sat Apr 12 2014 J. D. User <jduser@noreply.com> 1.18.1
270 - update to 1.18.1
272 * Sat Mar 08 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
273 - New Fedora packaging guidelines suggest to use pkgconfig() for BRs
275 * Tue Mar 04 2014 J. D. User <jduser@noreply.com> 1.18.0-*git*
276 - F20+ require libnice-gstreamer for correct operation
278 * Sat Jan 11 2014 J. D. User <jduser@noreply.com> 1.18.0
279 - update to 1.18.0
281 * Wed Dec 11 2013 J. D. User <jduser@noreply.com> 1.17.3
282 - update to 1.17.3
284 * Sat Nov 30 2013 J. D. User <jduser@noreply.com> 1.17.2
285 - update to 1.17.2
287 * Sat Nov 16 2013 J. D. User <jduser@noreply.com> 1.17.1
288 - update to 1.17.1
290 * Sat Sep 21 2013 J. D. User <jduser@noreply.com> 1.17.0
291 - update to 1.17.0
293 * Sat Jul 13 2013 J. D. User <jduser@noreply.com> 1.16.1
294 - update to 1.16.1
296 * Fri Jun 14 2013 J. D. User <jduser@noreply.com> 1.16.0
297 - update to 1.16.0
299 * Thu May 16 2013 J. D. User <jduser@noreply.com> 1.15.1-*git*
300 - BR glib-2.0 >= 2.28.0 no longer required for Voice & Video features
302 * Sun Apr 07 2013 J. D. User <jduser@noreply.com> 1.15.1
303 - update to 1.15.1
305 * Fri Mar 29 2013 J. D. User <jduser@noreply.com> 1.15.0-*git*
306 - update package description texts
308 * Sat Mar 09 2013 J. D. User <jduser@noreply.com> 1.15.0
309 - update to 1.15.0
311 * Wed Dec 26 2012 J. D. User <jduser@noreply.com> 1.14.1
312 - update to 1.14.1
314 * Sun Dec 16 2012 J. D. User <jduser@noreply.com> 1.14.0
315 - update to 1.14.0
317 * Sun Sep 09 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
318 - BR telepathy-glib-devel >= 0.18.0
320 * Wed Sep 05 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
321 - BR telepathy-glib-devel >= 0.14.0
323 * Mon Aug 27 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
324 - add ktp-accounts-kcm-sipe package
326 * Sun Aug 26 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
327 - telepathy now requires glib-2.0 >= 2.22.0
328 - use "--without telepathy" to disable telepathy packages
330 * Fri Aug 24 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
331 - add empathy-sipe package
333 * Wed Aug 22 2012 J. D. User <jduser@noreply.com> 1.13.3-*git*
334 - add telepathy-sipe & sipe-common packages
336 * Sun Aug 19 2012 J. D. User <jduser@noreply.com> 1.13.3
337 - update to 1.13.3
339 * Sun Jun 10 2012 J. D. User <jduser@noreply.com> 1.13.2
340 - update to 1.13.2
342 * Mon Apr 09 2012 J. D. User <jduser@noreply.com> 1.13.1
343 - update to 1.13.1
345 * Wed Mar 14 2012 J. D. User <jduser@noreply.com> 1.13.0
346 - update to 1.13.0
348 * Mon Dec 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
349 - we do support Microsoft Lync Server 2010 now.
351 * Tue Dec 06 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
352 - update GPL2 license name
354 * Sat Nov 12 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
355 - add BR gmime-devel
357 * Mon Oct 31 2011 J. D. User <jduser@noreply.com> 1.12.0-*git*
358 - add BR nss-devel
360 * Mon Aug 29 2011 J. D. User <jduser@noreply.com> 1.12.0
361 - update to 1.12.0
363 * Wed Jun 22 2011 J. D. User <jduser@noreply.com> 1.11.2-*git*
364 - add "--with vv" option to enable Voice & Video features
366 * Tue Nov 02 2010 J. D. User <jduser@noreply.com> 1.11.2
367 - update to 1.11.2
369 * Sun Oct 24 2010 J. D. User <jduser@noreply.com> 1.11.1
370 - update to 1.11.1
372 * Sun Oct 04 2010 J. D. User <jduser@noreply.com> 1.11.0
373 - update to 1.11.0
375 * Fri Sep 02 2010 J. D. User <jduser@noreply.com> 1.10.1-*git*
376 - add (commented out) BR libnice-devel
378 * Sun Jun 27 2010 J. D. User <jduser@noreply.com> 1.10.1
379 - update to 1.10.1
381 * Mon Apr 12 2010 J. D. User <jduser@noreply.com> 1.10.0-*git*
382 - add (commented out) BR nss-devel
384 * Sun Apr 04 2010 J. D. User <jduser@noreply.com> 1.10.0
385 - update to 1.10.0
387 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
388 - changed --with/--without options to --enable/--disable
390 * Sun Mar 28 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
391 - removed --with-krb5 configure option as it is autodetected now
393 * Tue Mar 23 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
394 - add SVG icon
396 * Sat Mar 20 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
397 - add BR glib2-devel >= 2.12.0
399 * Wed Mar 17 2010 J. D. User <jduser@noreply.com> 1.9.1-*git*
400 - add tests to build
402 * Tue Mar 16 2010 J. D. User <jduser@noreply.com> 1.9.1
403 - update to 1.9.1
405 * Thu Mar 11 2010 J. D. User <jduser@noreply.com> 1.9.0-*git*
406 - add BR libxml2-devel
408 * Wed Mar 10 2010 J. D. User <jduser@noreply.com> 1.9.0
409 - update to 1.9.0
411 * Mon Mar 08 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
412 - increased libpurple build requisite to >= 2.4.0
414 * Sun Mar 07 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
415 - sync with RPM SPEC from contrib/OBS
417 * Sat Mar 06 2010 J. D. User <jduser@noreply.com> 1.8.1-*git*
418 - update package summary & description
420 * Tue Feb 16 2010 J. D. User <jduser@noreply.com> 1.8.1
421 - update to 1.8.1
423 * Sun Feb 07 2010 J. D. User <jduser@noreply.com> 1.8.0
424 - update to 1.8.0
426 * Thu Jan 14 2010 J. D. User <jduser@noreply.com> 1.7.1-*git*
427 - autogen.sh no longer runs configure
429 * Tue Dec 29 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
430 - add configure parameters for purple and telepathy
432 * Sat Dec 12 2009 J. D. User <jduser@noreply.com> 1.7.1-*git*
433 - add Epoch: for git packages to avoid update clash with official packages
435 * Mon Nov 19 2009 J. D. User <jduser@noreply.com> 1.7.1
436 - update to 1.7.1
438 * Mon Oct 28 2009 J. D. User <jduser@noreply.com> 1.7.0-*git*
439 - add missing Group: to purple-sipe
441 * Mon Oct 19 2009 J. D. User <jduser@noreply.com> 1.7.0
442 - update to 1.7.0
444 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
445 - move non-Pidgin files to new sub-package purple-sipe
447 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
448 - remove directory for emoticon theme icons
450 * Sun Oct 11 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
451 - libpurple protocol plugins are located under %{_libdir}/purple-2
453 * Mon Sep 28 2009 J. D. User <jduser@noreply.com> 1.6.3-*git*
454 - added directory for emoticon theme icons
456 * Wed Sep 09 2009 J. D. User <jduser@noreply.com> 1.6.3
457 - update to 1.6.3
459 * Fri Aug 28 2009 J. D. User <jduser@noreply.com> 1.6.2-*git*
460 - reduce libpurple-devel requirement to >= 2.3.1
462 * Mon Aug 24 2009 J. D. User <jduser@noreply.com> 1.6.2
463 - update to 1.6.2
465 * Fri Aug 21 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
466 - reduce libpurple-devel requirement to >= 2.4.1
468 * Mon Aug 17 2009 J. D. User <jduser@noreply.com> 1.6.1-*git*
469 - com_err.h only required for kerberos
471 * Tue Aug 11 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
472 - require libpurple-devel >= 2.5.0
474 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
475 - refactor configure parameters
476 - make kerberos configurable
477 - don't hard code prefix for git builds
479 * Sun Aug 09 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
480 - removed unnecessary zlib-devel
482 * Sat Aug 08 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
483 - fix prefix for git builds
485 * Sat Aug 01 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
486 - append -Wno-unused-parameter for GCC <4.4 compilation errors
488 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
489 - remove duplicate GPL2
491 * Thu Jul 30 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
492 - use "--with git" to build from git
493 - corrected download URL for release archive
494 - add missing BR gettext-devel
496 * Wed Jul 29 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
497 - use default rpmbuild CFLAGS also for git builds
498 - merge with SPEC files created by mricon & jberanek
500 * Tue Jul 28 2009 J. D. User <jduser@noreply.com> 1.6.0-*git*
501 - initial RPM SPEC example generated