Document some requirements in the README.
authorJonas Häggqvist <rasher@rasher.dk>
Tue, 17 Mar 2009 22:21:47 +0000 (17 23:21 +0100)
committerJonas Häggqvist <rasher@rasher.dk>
Tue, 17 Mar 2009 22:21:47 +0000 (17 23:21 +0100)
README

diff --git a/README b/README
index 1cd75d4..f8c099b 100644 (file)
--- a/README
+++ b/README
@@ -1,7 +1,13 @@
+== REQUIREMENTS ==
+
+1. Apache with PHP5
+2. Smarty (http://smarty.net/ or the 'smarty' package on Debian systems)
+3. magic_quotes_gpc = Off in your apache config (or .htaccess)
+
 == INSTALLATION ==
 
 1. Put the dir "public" somewhere where your webserver can see it. If you're
-   running the site, making it the document root is expected.
+   running the main site, making it the document root is expected.
 2. Edit public/preconfig.inc.php to point to the location of
    private/config.inc.php. This directory should absolutely NOT be reachable
    through the webserver.
@@ -11,6 +17,7 @@
     - private/templates/cache
     - private/templates/compiled
     - public/themes
+    - private/themes
 5. Compile checkwps for all targets and put them in private/checkwps/release
    and private/checkwps/current. Put their versions in a file named VERSION
    in each dir. See private/checkwps/current/update.sh for an easy way to do