switch back to gemspec development dependencies
authorEric Wong <normalperson@yhbt.net>
Sat, 13 Apr 2013 02:23:22 +0000 (13 02:23 +0000)
committerEric Wong <normalperson@yhbt.net>
Sat, 13 Apr 2013 02:24:55 +0000 (13 02:24 +0000)
This is more standardized than bundler for gem development.

.gitignore
Gemfile [deleted file]
raindrops.gemspec

index 52fa812..0a82218 100644 (file)
@@ -14,5 +14,3 @@ Makefile
 /LATEST
 /tmp
 /.rbx
-# http://yehudakatz.com/2010/12/16/clarifying-the-roles-of-the-gemspec-and-gemfile/
-/Gemfile.lock
diff --git a/Gemfile b/Gemfile
deleted file mode 100644 (file)
index c9a1b64..0000000
--- a/Gemfile
+++ /dev/null
@@ -1,6 +0,0 @@
-source(ENV["GEM_SOURCE"] || :rubygems)
-gem 'aggregate', '~> 0.2'
-gem 'io-extra', '~> 1.2.3'
-gem 'posix_mq', '~> 1.0'
-gem 'rack', '~> 1.2'
-gem 'unicorn', '>= 0.98'
index dc44b75..ed8eaf5 100644 (file)
@@ -22,7 +22,11 @@ Gem::Specification.new do |s|
   s.rdoc_options = rdoc_options
   s.rubyforge_project = %q{rainbows}
   s.test_files = test_files
-  s.add_development_dependency('bundler', '~> 1.0.10')
+  s.add_development_dependency('aggregate', '~> 0.2')
+  s.add_development_dependency('io-extra', [ '~> 1.2', '>= 1.2.3'])
+  s.add_development_dependency('posix_mq', '~> 2.0')
+  s.add_development_dependency('rack', '~> 1.2')
+  s.add_development_dependency('unicorn', '>= 0.98')
 
   # s.licenses = %w(LGPLv3) # accessor not compatible with older RubyGems
 end