license: use LGPLv2.1 or later (was LGPL (2.1|3.0)-only)
authorEric Wong <normalperson@yhbt.net>
Tue, 18 Feb 2014 08:11:31 +0000 (18 08:11 +0000)
committerEric Wong <normalperson@yhbt.net>
Tue, 18 Feb 2014 08:11:31 +0000 (18 08:11 +0000)
There is currently no LGPLv4, so this change has no effect at the
moment.

In case the LGPLv4 arrives and I am not alive to approve/review it,
the lesser of evils is have give blanket approval of all future LGPL
versions (as published by the FSF).  The worse evil is to be stuck
with a license which cannot guarantee the Free-ness of this project
in the future.

This unfortunately means the FSF can theoretically come out with
license terms I do not agree with, but the LGPLv2.1 and LGPLv3
will always remain an option to all users.

LICENSE
raindrops.gemspec

diff --git a/LICENSE b/LICENSE
index 4dde807..a3dbff6 100644 (file)
--- a/LICENSE
+++ b/LICENSE
@@ -4,9 +4,8 @@ revision control for names and email addresses of all of them.
 You can redistribute it and/or modify it under the terms of the GNU
 Lesser General Public License (LGPL) as published by the Free Software
 Foundation, version {2.1}[http://www.gnu.org/licenses/lgpl-2.1.txt] or
-or {3}[http://www.gnu.org/licenses/lgpl-3.0.txt] (see link:COPYING).
-The raindrops project leader (Eric Wong) reserves the right to
-relicense raindrops under future versions of the LGPL.
+later.  Currently version {3}[http://www.gnu.org/licenses/lgpl-3.0.txt],
+is preferred (see link:COPYING).
 
 raindrops is distributed in the hope that it will be useful, but WITHOUT
 ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
@@ -14,5 +13,4 @@ FITNESS FOR A PARTICULAR PURPOSE.  See the GNU Lesser General Public
 License for more details.
 
 You should have received a copy of the GNU Lesser General Public License
-along with the raindrops; if not, write to the Free Software
-Foundation, Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301
+along with the raindrops; if not, see <http://www.gnu.org/licenses/>
index 2a51b88..c5d6e87 100644 (file)
@@ -29,5 +29,5 @@ Gem::Specification.new do |s|
   s.add_development_dependency('unicorn', '>= 0.98')
   s.add_development_dependency('wrongdoc', ['~> 1.6.2', '>= 1.6.2'])
 
-  # s.licenses = %w(LGPLv3) # accessor not compatible with older RubyGems
+  s.licenses = %w(LGPLv2.1+)
 end