bump unicorn dependency to 4.6.2+ for Ruby 2.0.0
authorEric Wong <normalperson@yhbt.net>
Tue, 26 Feb 2013 03:16:46 +0000 (26 03:16 +0000)
committerEric Wong <normalperson@yhbt.net>
Tue, 26 Feb 2013 03:16:46 +0000 (26 03:16 +0000)
This ensures we're compatible with the latest stable
Ruby version.

rainbows.gemspec
t/test_isolate.rb

index bcbbf5b..6a906cf 100644 (file)
@@ -28,7 +28,9 @@ Gem::Specification.new do |s|
   s.add_dependency(%q<kgio>, ['~> 2.5'])
 
   # we need Unicorn for the HTTP parser and process management
-  s.add_dependency(%q<unicorn>, ["~> 4.6"]) # 4.6.0+ supports hijacking
+  # 4.6.0+ supports hijacking, 4.6.2 fixes the chunk parser (for Ruby 2.0.0)
+  s.add_dependency(%q<unicorn>, ["~> 4.6", ">= 4.6.2"])
+
   s.add_development_dependency(%q<isolate>, "~> 3.1")
   s.add_development_dependency(%q<wrongdoc>, "~> 1.6")
 
index 6b7fe5a..d5daa8c 100644 (file)
@@ -20,7 +20,7 @@ Isolate.now!(opts) do
   gem 'rack', '1.5.2'
   gem 'kcar', '0.4.0'
   gem 'raindrops', '0.10.0'
-  gem 'unicorn', '4.6.0'
+  gem 'unicorn', '4.6.2'
 
   if engine == "ruby"
     gem 'sendfile', '1.1.0'