gemspec: set licenses= attribute
authorEric Wong <normalperson@yhbt.net>
Tue, 26 Feb 2013 03:14:26 +0000 (26 03:14 +0000)
committerEric Wong <normalperson@yhbt.net>
Tue, 26 Feb 2013 03:16:36 +0000 (26 03:16 +0000)
Old versions of RubyGems which could not handle this attribute
are likely no longer in use.

rainbows.gemspec

index c29f308..bcbbf5b 100644 (file)
@@ -53,6 +53,7 @@ Gem::Specification.new do |s|
   # NeverBlock, currently only available on http://gems.github.com/
   # s.add_dependency(%q<espace-neverblock>, ["~> 0.1.6.1"])
 
-  # accessor not compatible with older RubyGems
-  # s.licenses = %w(GPLv3 GPLv2 Ruby)
+  # We inherited the Ruby 1.8 license from Mongrel, so we're stuck with it.
+  # GPLv3 is preferred.
+  s.licenses = ["GPLv2", "GPLv3", "Ruby 1.8"]
 end