added LDFLAGS to makefile
authorAlex Montgomery <apmontgo@users.sourceforge.net>
Sat, 28 May 2011 12:05:21 +0000 (28 13:05 +0100)
committerAlex Montgomery <apmontgo@users.sourceforge.net>
Sat, 28 May 2011 12:05:21 +0000 (28 13:05 +0100)
GNUmakefile.in
configure

index 46d5b80..789c586 100644 (file)
@@ -37,7 +37,7 @@ uninstall: @ac_default_uninstall@
        $(CC) $(CFLAGS) $(PKG_CFLAGS) -c $<
 
 jackctlmmc: $(OBJECTS)
-       $(CC) $(CFLAGS) $(PKG_CFLAGS) $(LIBS) -o $@ $(OBJECTS)
+       $(CC) $(CFLAGS) $(PKG_CFLAGS) $(LDFLAGS) -o $@ $(OBJECTS) $(LIBS)
 
 qjackmmc:
        cd qt && $(QMAKE) -o Makefile qjackmmc.pro && $(MAKE)
index f4aafab..a45168a 100755 (executable)
--- a/configure
+++ b/configure
@@ -706,9 +706,6 @@ CPPFLAGS
 CCC
 CC
 CFLAGS
-LDFLAGS
-LIBS
-CPPFLAGS
 PKG_CONFIG
 PKG_CONFIG_PATH
 PKG_CONFIG_LIBDIR
@@ -717,7 +714,6 @@ REQUIREDPKGS_LIBS
 QT_UP_TO_DATE_CFLAGS
 QT_UP_TO_DATE_LIBS
 CXXCPP
-CPPFLAGS
 LASH_CFLAGS
 LASH_LIBS'
 
@@ -3698,6 +3694,7 @@ done
 
 
 
+
 if test "x$ac_cv_env_PKG_CONFIG_set" != "xset"; then
        if test -n "$ac_tool_prefix"; then
   # Extract the first word of "${ac_tool_prefix}pkg-config", so it can be a program name with args.
@@ -3828,6 +3825,7 @@ if test -n "$REQUIREDPKGS_CFLAGS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_REQUIREDPKGS_CFLAGS=`$PKG_CONFIG --cflags "jack >= 0.99.0 alsa >= 1.0.0" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -3844,6 +3842,7 @@ if test -n "$REQUIREDPKGS_LIBS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_REQUIREDPKGS_LIBS=`$PKG_CONFIG --libs "jack >= 0.99.0 alsa >= 1.0.0" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -3863,9 +3862,9 @@ else
         _pkg_short_errors_supported=no
 fi
         if test $_pkg_short_errors_supported = yes; then
-               REQUIREDPKGS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "jack >= 0.99.0 alsa >= 1.0.0" 2>&1`
+               REQUIREDPKGS_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "jack >= 0.99.0 alsa >= 1.0.0" 2>&1`
         else
-               REQUIREDPKGS_PKG_ERRORS=`$PKG_CONFIG --print-errors "jack >= 0.99.0 alsa >= 1.0.0" 2>&1`
+               REQUIREDPKGS_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "jack >= 0.99.0 alsa >= 1.0.0" 2>&1`
         fi
        # Put the nasty error message in config.log where it belongs
        echo "$REQUIREDPKGS_PKG_ERRORS" >&5
@@ -3923,6 +3922,7 @@ if test -n "$QT_UP_TO_DATE_CFLAGS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_QT_UP_TO_DATE_CFLAGS=`$PKG_CONFIG --cflags "QtCore >= 4.4" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -3939,6 +3939,7 @@ if test -n "$QT_UP_TO_DATE_LIBS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_QT_UP_TO_DATE_LIBS=`$PKG_CONFIG --libs "QtCore >= 4.4" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -3958,9 +3959,9 @@ else
         _pkg_short_errors_supported=no
 fi
         if test $_pkg_short_errors_supported = yes; then
-               QT_UP_TO_DATE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "QtCore >= 4.4" 2>&1`
+               QT_UP_TO_DATE_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "QtCore >= 4.4" 2>&1`
         else
-               QT_UP_TO_DATE_PKG_ERRORS=`$PKG_CONFIG --print-errors "QtCore >= 4.4" 2>&1`
+               QT_UP_TO_DATE_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "QtCore >= 4.4" 2>&1`
         fi
        # Put the nasty error message in config.log where it belongs
        echo "$QT_UP_TO_DATE_PKG_ERRORS" >&5
@@ -4656,6 +4657,7 @@ if test -n "$LASH_CFLAGS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_LASH_CFLAGS=`$PKG_CONFIG --cflags "lash-1.0 >= 0.5.0" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -4672,6 +4674,7 @@ if test -n "$LASH_LIBS"; then
   $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
   test $ac_status = 0; }; then
   pkg_cv_LASH_LIBS=`$PKG_CONFIG --libs "lash-1.0 >= 0.5.0" 2>/dev/null`
+                     test "x$?" != "x0" && pkg_failed=yes
 else
   pkg_failed=yes
 fi
@@ -4691,9 +4694,9 @@ else
         _pkg_short_errors_supported=no
 fi
         if test $_pkg_short_errors_supported = yes; then
-               LASH_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "lash-1.0 >= 0.5.0" 2>&1`
+               LASH_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors --cflags --libs "lash-1.0 >= 0.5.0" 2>&1`
         else
-               LASH_PKG_ERRORS=`$PKG_CONFIG --print-errors "lash-1.0 >= 0.5.0" 2>&1`
+               LASH_PKG_ERRORS=`$PKG_CONFIG --print-errors --cflags --libs "lash-1.0 >= 0.5.0" 2>&1`
         fi
        # Put the nasty error message in config.log where it belongs
        echo "$LASH_PKG_ERRORS" >&5