initial import
[gentoo-soor-overlay.git] / x11-libs / qt / qt-4.3.2-r1.ebuild
blob12c91c27113e86c22790b6f3877b08827cdf7ba9
1 # Copyright 1999-2007 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: Exp $
5 inherit eutils flag-o-matic toolchain-funcs multilib
7 SRCTYPE="opensource-src"
8 QT_COPY_SNAP="20071205"
9 DESCRIPTION="The Qt toolkit is a comprehensive C++ application development framework."
10 HOMEPAGE="http://www.trolltech.com/"
12 RESTRICT="primaryuri"
14 SRC_URI="ftp://ftp.trolltech.com/pub/qt/source/qt-x11-${SRCTYPE}-${PV}.tar.gz
15 qt-copy? ( http://eruonen.serveblog.net/patches/qt-copy-${PV}-patches-${QT_COPY_SNAP}.tar.bz2 )"
16 S=${WORKDIR}/qt-x11-${SRCTYPE}-${PV}
18 LICENSE="|| ( QPL-1.0 GPL-2 )"
19 SLOT="4"
20 KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
22 IUSE_INPUT_DEVICES="input_devices_wacom"
24 IUSE="accessibility cups dbus debug doc examples firebird gif glib jpeg mng mysql nas nis odbc opengl pch png postgres qt-copy qt3support sqlite sqlite3 ssl tiff xinerama zlib ${IUSE_INPUT_DEVICES}"
26 RDEPEND="x11-libs/libXrandr
27 x11-libs/libXcursor
28 x11-libs/libXfont
29 x11-libs/libSM
30 xinerama? ( x11-libs/libXinerama )
31 media-libs/fontconfig
32 >=media-libs/freetype-2
33 png? ( media-libs/libpng )
34 jpeg? ( media-libs/jpeg )
35 mng? ( >=media-libs/libmng-1.0.9 )
36 tiff? ( media-libs/tiff )
37 nas? ( >=media-libs/nas-1.5 )
38 odbc? ( dev-db/unixODBC )
39 mysql? ( virtual/mysql )
40 firebird? ( dev-db/firebird )
41 sqlite3? ( =dev-db/sqlite-3* )
42 sqlite? ( =dev-db/sqlite-2* )
43 opengl? ( virtual/opengl virtual/glu )
44 postgres? ( dev-db/libpq )
45 cups? ( net-print/cups )
46 zlib? ( sys-libs/zlib )
47 glib? ( dev-libs/glib )
48 dbus? ( >=sys-apps/dbus-1.0.2 )
49 ssl? ( dev-libs/openssl )
50 input_devices_wacom? ( x11-libs/libXi x11-drivers/linuxwacom )"
52 DEPEND="${RDEPEND}
53 xinerama? ( x11-proto/xineramaproto )
54 x11-proto/xextproto
55 x11-proto/inputproto
56 dev-util/pkgconfig"
58 pkg_setup() {
59 QTBASEDIR=/usr/$(get_libdir)/qt4
60 QTPREFIXDIR=/usr
61 QTBINDIR=/usr/bin
62 QTLIBDIR=/usr/$(get_libdir)/qt4
63 QTPCDIR=/usr/$(get_libdir)/pkgconfig
64 QTDATADIR=/usr/share/qt4
65 QTDOCDIR=/usr/share/doc/${PF}
66 QTHEADERDIR=/usr/include/qt4
67 QTPLUGINDIR=${QTLIBDIR}/plugins
68 QTSYSCONFDIR=/etc/qt4
69 QTTRANSDIR=${QTDATADIR}/translations
70 QTEXAMPLESDIR=${QTDATADIR}/examples
71 QTDEMOSDIR=${QTDATADIR}/demos
73 PLATFORM=$(qt_mkspecs_dir)
77 qt_use() {
78 local flag="$1"
79 local feature="$1"
80 local enableval=
82 [[ -n $2 ]] && feature=$2
83 [[ -n $3 ]] && enableval="-$3"
85 useq $flag && echo "${enableval}-${feature}" || echo "-no-${feature}"
86 return 0
89 qt_mkspecs_dir() {
90 # Allows us to define which mkspecs dir we want to use.
91 local spec
93 case ${CHOST} in
94 *-freebsd*|*-dragonfly*)
95 spec="freebsd" ;;
96 *-openbsd*)
97 spec="openbsd" ;;
98 *-netbsd*)
99 spec="netbsd" ;;
100 *-darwin*)
101 spec="darwin" ;;
102 *-linux-*|*-linux)
103 spec="linux" ;;
105 die "Unknown CHOST, no platform choosed."
106 esac
108 CXX=$(tc-getCXX)
109 if [[ ${CXX/g++/} != ${CXX} ]]; then
110 spec="${spec}-g++"
111 elif [[ ${CXX/icpc/} != ${CXX} ]]; then
112 spec="${spec}-icc"
113 else
114 die "Unknown compiler ${CXX}."
117 echo "${spec}"
120 src_unpack() {
122 unpack ${A}
123 cd "${S}"
124 epatch "${FILESDIR}"/qt-4.2.3-hppa-ldcw-fix.patch
126 epatch "${FILESDIR}"/qsslsocket-fix.patch
128 # Apply QT Copy patches:
129 if use qt-copy ; then
130 EPATCH_MULTI_MSG="Applying the KDE Qt Copy patches ..." \
131 EPATCH_SOURCE="${WORKDIR}/qt-copy-${PV}-patches-${QT_COPY_SNAP}" EPATCH_SUFFIX="diff" epatch
134 cd "${S}"/mkspecs/$(qt_mkspecs_dir)
135 # set c/xxflags and ldflags
137 # Don't let the user go too overboard with flags. If you really want to, uncomment
138 # out the line below and give 'er a whirl.
139 strip-flags
140 replace-flags -O3 -O2
142 if [[ $( gcc-fullversion ) == "3.4.6" && gcc-specs-ssp ]] ; then
143 ewarn "Appending -fno-stack-protector to CFLAGS/CXXFLAGS"
144 append-flags -fno-stack-protector
147 sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CFLAGS}:" \
148 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CXXFLAGS}:" \
149 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
150 -e "/CONFIG/s:$: nostrip:" \
151 qmake.conf
153 # Do not link with -rpath. See bug #75181.
154 sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" qmake.conf
156 # Replace X11R6/ directories, so /usr/X11R6/lib -> /usr/lib
157 sed -i -e "s:X11R6/::" qmake.conf
159 # The trolls moved the definitions of the above stuff for g++, so we need to edit those files
160 # separately as well.
161 cd "${S}"/mkspecs/common
163 sed -i -e "s:QMAKE_CFLAGS_RELEASE.*=.*:QMAKE_CFLAGS_RELEASE=${CPPFLAGS} ${CFLAGS} ${ASFLAGS}:" \
164 -e "s:QMAKE_CXXFLAGS_RELEASE.*=.*:QMAKE_CXXFLAGS_RELEASE=${CPPFLAGS} ${CXXFLAGS} ${ASFLAGS}:" \
165 -e "s:QMAKE_LFLAGS_RELEASE.*=.*:QMAKE_LFLAGS_RELEASE=${LDFLAGS}:" \
166 g++.conf
168 # Do not link with -rpath. See bug #75181.
169 sed -i -e "s:QMAKE_RPATH.*=.*:QMAKE_RPATH=:" g++.conf
171 # Replace X11R6/ directories, so /usr/X11R6/lib -> /usr/lib
172 sed -i -e "s:X11R6/::" linux.conf
174 cd "${S}"/qmake
176 sed -i -e "s:CXXFLAGS.*=:CXXFLAGS=${CPPFLAGS} ${CXXFLAGS} ${ASFLAGS} :" \
177 -e "s:LFLAGS.*=:LFLAGS=${LDFLAGS} :" Makefile.unix
179 cd "${S}"
183 src_compile() {
184 export PATH="${S}/bin:${PATH}"
185 export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
187 [ $(get_libdir) != "lib" ] && myconf="${myconf} -L/usr/$(get_libdir)"
189 # Disable visibility explicitly if gcc version isn't 4
190 if [[ "$(gcc-major-version)" != "4" ]]; then
191 myconf="${myconf} -no-reduce-exports"
194 # Add a switch that will attempt to use recent binutils to reduce relocations. Should be harmless for other
195 # cases. From bug #178535
196 myconf="${myconf} -reduce-relocations"
198 myconf="${myconf} $(qt_use accessibility) $(qt_use cups) $(qt_use xinerama)"
199 myconf="${myconf} $(qt_use opengl) $(qt_use nis)"
201 use nas && myconf="${myconf} -system-nas-sound"
203 myconf="${myconf} $(qt_use gif gif qt) $(qt_use png libpng system)"
204 myconf="${myconf} $(qt_use jpeg libjpeg system) $(qt_use tiff libtiff system)"
205 myconf="${myconf} $(qt_use zlib zlib system) $(qt_use mng libmng system)"
207 use debug && myconf="${myconf} -debug -no-separate-debug-info" || myconf="${myconf} -release -no-separate-debug-info"
209 use mysql && myconf="${myconf} -plugin-sql-mysql -I/usr/include/mysql -L/usr/$(get_libdir)/mysql" || myconf="${myconf} -no-sql-mysql"
210 use postgres && myconf="${myconf} -plugin-sql-psql -I/usr/include/postgresql/pgsql" || myconf="${myconf} -no-sql-psql"
211 use firebird && myconf="${myconf} -plugin-sql-ibase -I/opt/firebird/include" || myconf="${myconf} -no-sql-ibase"
212 use sqlite3 && myconf="${myconf} -plugin-sql-sqlite -system-sqlite" || myconf="${myconf} -no-sql-sqlite"
213 use sqlite && myconf="${myconf} -plugin-sql-sqlite2" || myconf="${myconf} -no-sql-sqlite2"
214 use odbc && myconf="${myconf} -plugin-sql-odbc" || myconf="${myconf} -no-sql-odbc"
216 use dbus && myconf="${myconf} -qdbus" || myconf="${myconf} -no-qdbus"
217 use glib && myconf="${myconf} -glib" || myconf="${myconf} -no-glib"
218 use qt3support && myconf="${myconf} -qt3support" || myconf="${myconf} -no-qt3support"
219 use ssl && myconf="${myconf} -openssl" || myconf="${myconf} -no-openssl"
221 use pch && myconf="${myconf} -pch" || myconf="${myconf} -no-pch"
223 use input_devices_wacom && myconf="${myconf} -tablet" || myconf="${myconf} -no-tablet"
225 myconf="${myconf} -xrender -xrandr -xkb -xshape -sm"
227 if ! use examples; then
228 myconf="${myconf} -nomake examples"
231 myconf="-stl -verbose -largefile -confirm-license \
232 -platform ${PLATFORM} -xplatform ${PLATFORM} -no-rpath \
233 -prefix ${QTPREFIXDIR} -bindir ${QTBINDIR} -libdir ${QTLIBDIR} -datadir ${QTDATADIR} \
234 -docdir ${QTDOCDIR} -headerdir ${QTHEADERDIR} -plugindir ${QTPLUGINDIR} \
235 -sysconfdir ${QTSYSCONFDIR} -translationdir ${QTTRANSDIR} \
236 -examplesdir ${QTEXAMPLESDIR} -demosdir ${QTDEMOSDIR} ${myconf}"
238 echo ./configure ${myconf}
239 ./configure ${myconf} || die
241 emake all || die
244 src_install() {
245 export PATH="${S}/bin:${PATH}"
246 export LD_LIBRARY_PATH="${S}/lib:${LD_LIBRARY_PATH}"
248 emake INSTALL_ROOT="${D}" install_subtargets || die
249 emake INSTALL_ROOT="${D}" install_qmake || die
250 emake INSTALL_ROOT="${D}" install_mkspecs || die
252 if use doc; then
253 emake INSTALL_ROOT="${D}" install_htmldocs || die
256 # Install the translations. This may get use flagged later somehow
257 emake INSTALL_ROOT="${D}" install_translations || die
259 keepdir "${QTSYSCONFDIR}"
261 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/*.la
262 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/*.prl
263 sed -i -e "s:${S}/lib:${QTLIBDIR}:g" "${D}"/${QTLIBDIR}/pkgconfig/*.pc
265 # pkgconfig files refer to WORKDIR/bin as the moc and uic locations. Fix:
266 sed -i -e "s:${S}/bin:${QTBINDIR}:g" "${D}"/${QTLIBDIR}/pkgconfig/*.pc
268 # Move .pc files into the pkgconfig directory
269 dodir ${QTPCDIR}
270 mv "${D}"/${QTLIBDIR}/pkgconfig/*.pc "${D}"/${QTPCDIR}
272 # Install .desktop files, from bug #174033
273 insinto /usr/share/applications
274 doins "${FILESDIR}"/qt4/*.desktop
276 # List all the multilib libdirs
277 local libdirs
278 for libdir in $(get_all_libdirs); do
279 libdirs="${libdirs}:/usr/${libdir}/qt4"
280 done
282 cat > "${T}/44qt4" << EOF
283 LDPATH=${libdirs:1}
284 QMAKESPEC=$(qt_mkspecs_dir)
286 doenvd "${T}/44qt4"