net-libs/webkitgtk: add nightly build.
[gentoo-soor-overlay.git] / net-libs / webkitgtk / webkitgtk-33029.ebuild
blobd3736ba016bd614ff7bbc2d0a6d936fd5a0af092
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI="1"
7 inherit autotools flag-o-matic
9 RESTRICT="primaryuri"
11 DESCRIPTION="Open source web browser engine"
12 HOMEPAGE="http://www.webkit.org/"
13 MY_P="WebKit-r${PV}"
14 SRC_URI="http://nightly.webkit.org/files/trunk/src/${MY_P}.tar.bz2"
16 LICENSE="LGPL-2 LGPL-2.1 BSD"
17 SLOT="0"
18 KEYWORDS="~amd64 ~x86 ~ppc"
19 IUSE="debug gstreamer hildon +pango soup +sqlite +svg"
21 S="${WORKDIR}"/${MY_P}
23 # FIXME: ask 'alp' or 'kalikiana' about libsoup and pango
24 # version needed.
25 RDEPEND="x11-libs/gtk+:2
26 dev-libs/icu
27 media-libs/jpeg
28 media-libs/libpng:1.2
29 dev-libs/libxslt
30 dev-libs/libxml2:2
31 !pango? ( media-libs/freetype:2 )
32 pango? ( >=x11-libs/pango-1.20 )
33 !soup? ( >=net-misc/curl-7.15 )
34 soup? ( net-libs/libsoup:2.4 )
35 sqlite? ( dev-db/sqlite:3 )
36 gstreamer? (
37 media-libs/gstreamer:0.10
38 media-libs/gst-plugins-base:0.10
39 gnome-base/gnome-vfs:2
42 DEPEND="${RDEPEND}
43 sys-devel/bison
44 dev-util/gperf
45 >=sys-devel/flex-2.5.33"
47 pkg_setup() {
48 if use pango && ! built_with_use 'x11-libs/pango' X; then
49 eerror "You must build pango with USE=X in order"
50 eerror "to use it as a font backend for webkit-gtk"
51 die "please rebuild pango with X enabled"
53 if ! use pango && ! built_with_use 'media-libs/freetype:2' X; then
54 eerror "You must build pango with USE=X in order"
55 eerror "to use it as a font backend for webkit-gtk"
56 die "please rebuild pango with X enabled"
58 if use soup && ! built_with_use 'net-libs/libsoup:2.4' ssl; then
59 eerror "You must build libsoup with USE=ssl in order"
60 eerror "to use it as an http backend for webkit-gtk"
61 die "please rebuild libsoup with ssl enabled"
63 if ! use soup && ! built_with_use --missing false -o 'net-misc/curl' gnutls nss ssl; then
64 eerror "You must build curl with USE gnutls or nss or ssl in order"
65 eerror "to use it as an http backend for webkit-gtk"
66 die "please rebuild libsoup with one of gnutls nss or ssl enabled"
70 src_unpack() {
71 unpack ${A}
72 cd "${S}"
74 eautoreconf
77 src_compile() {
78 strip-flags
80 local myopts
82 if use soup; then
83 einfo "Selected libsoup http backend."
84 myopts="--with-font-backend=soup"
85 else
86 einfo "Selected curl http backend."
87 myopts="--with-font-backend=curl"
90 if use pango; then
91 einfo "Using pango font backend."
92 myopts="${myopts} --with-font-backend=pango"
93 else
94 einfo "Using freetype font backend."
95 myopts="${myopts} --with-font-backend=freetype"
98 econf ${myopts} \
99 $(use_with hildon) \
100 $(use_enable sqlite database) \
101 $(use_enable sqlite icon-database) \
102 $(use_enable sqlite dom-storage) \
103 $(use_enable gstreamer video) \
104 $(use_enable svg svg-experimental) \
105 $(use_enable debug)
107 emake || die "emake failed"
110 src_install() {
111 emake DESTDIR="${D}" install || die "Install failed"