Add gnome-commander.
[gentoo-soor-overlay.git] / app-misc / gnome-commander / gnome-commander-1.3.0.99.ebuild
blob803431563afdad355f99211f52e7f98565d9f4ae
1 # Copyright 1999-2008 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License, v2 or later
3 # $Header:
5 inherit gnome2 flag-o-matic subversion autotools
7 DESCRIPTION="A full featured, dual-pane file manager for Gnome2"
8 HOMEPAGE="http://www.nongnu.org/gcmd/"
10 ESVN_REPO_URI="svn://svn.gnome.org/svn/gnome-commander/branches/gcmd-1-3"
11 SRC_URI=""
13 KEYWORDS=""
15 LICENSE="GPL-2"
17 IUSE="doc exif gsf id3 python"
18 SLOT="0"
20 USE_DESC="exif: add support for Exif and IPTC
21 gsf: add support for OLE, OLE2 and ODF
22 id3: add support for ID3, Vorbis, FLAC and APE
23 python: add support for python plugins"
25 RDEPEND=">=x11-libs/gtk+-2.8.0
26 >=dev-libs/glib-2.6.0
27 >=gnome-base/libgnomeui-2.4.0
28 >=gnome-base/libgnome-2.4.0
29 >=gnome-base/gnome-vfs-2.0
30 virtual/fam
31 exif? ( >=media-gfx/exiv2-0.14 )
32 gsf? ( >=gnome-extra/libgsf-1.12.0 )
33 id3? ( >=media-libs/taglib-1.4 )
34 python? ( >=dev-lang/python-2.4 )"
36 DEPEND="${RDEPEND}
37 dev-util/intltool
38 dev-util/pkgconfig"
40 DOCS="AUTHORS BUGS ChangeLog NEWS README TODO"
42 pkg_setup() {
43 G2CONF=" ${G2CONF}
44 $(use_with exif exiv2)
45 $(use_with gsf libgsf)
46 $(use_with id3 taglib)
47 $(use_enable python python)"
49 filter-ldflags -Wl,--as-needed
52 src_unpack() {
53 subversion_fetch || die "svn fetch failed"
55 cd "${S}"
57 WANT_AUTOMAKE="1.8"
58 AT_M4DIR="./m4"
59 AT_NOELIBTOOLIZE="yes"
60 eautoreconf || die "eautoreconf failed"
62 gnome2_omf_fix || die "Gnome2 OMF Fix failed"
64 elibtoolize ${ELTCONF} || die "elibtoolize failed"
66 cp ${ROOT}/usr/share/intltool/intltool-update.in .