qtads: add 2.1.6, remove old, update live ebuild
[gentoo-interactive-fiction.git] / games-engines / fizmo / fizmo-0.7.4.ebuild
blob355b06b923167d45d200c3c46814bc43c7930bdc
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=4
7 inherit eutils games
9 DESCRIPTION="Yet another Z-machine interpreter"
10 HOMEPAGE="http://www.spellbreaker.org/~chrender/fizmo/"
11 SRC_URI="http://www.spellbreaker.org/~chrender/fizmo/source/${P}.tar.gz"
13 LICENSE="BSD"
14 SLOT="0"
15 KEYWORDS="amd64 x86"
16 IUSE="+aiff +jpeg +png +X"
17 REQUIRED_USE="jpeg? ( X ) png? ( X )"
19 RDEPEND="jpeg? ( virtual/jpeg )
20 png? ( media-libs/libpng )
21 X? ( x11-libs/libX11 )
22 sys-libs/ncurses[unicode]
23 media-libs/libsdl
24 aiff? ( media-libs/libsndfile )
25 dev-libs/libxml2"
26 DEPEND="${RDEPEND}
27 dev-util/pkgconfig"
29 DOCS="CHANGELOG.txt README-0.7.txt README.txt user-config-example.txt"
31 src_configure() {
32 egamesconf \
33 $(use_enable aiff) \
34 $(use_enable jpeg) \
35 $(use_enable png) \
36 $(use_enable X x11)
39 src_install() {
40 emake DESTDIR="${D}" install
41 dodoc ${DOCS}
42 prepgamesdirs