ce3294389ac66e2d1d37f016acd450e312f93814
[gentoo-interactive-fiction.git] / games-engines / hugor / hugor-0.9.ebuild
blobce3294389ac66e2d1d37f016acd450e312f93814
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=3
6 inherit eutils fdo-mime games qt4-r2 confutils
7 if [ "$PV" != "9999" ]; then
8 SRC_URI="http://foss.aegean.gr/~realnc/hugor/${P}.tar.bz2"
9 KEYWORDS="x86 amd64"
10 else
11 SRC_URI=""
12 EGIT_REPO_URI="git://git.assembla.com/hugor.git"
13 KEYWORDS=""
14 inherit git-2
17 DESCRIPTION="Multimedia interpreter for Hugo text adventures"
18 HOMEPAGE="http://ifwiki.org/index.php/Hugor"
20 LICENSE="Hugo"
21 SLOT="0"
22 IUSE="fmod +sdl"
24 DEPEND="x11-libs/qt-gui:4
25 sdl? ( >=media-libs/sdl-mixer-1.2.12[mad,midi,modplug] )
26 fmod? ( media-libs/fmod )
27 x11-misc/shared-mime-info"
29 pkg_setup() {
30 confutils_require_one fmod sdl
33 src_configure() {
34 if use sdl; then
35 eqmake4 SOUND=sdl
36 else
37 eqmake4 SOUND=fmod
41 src_install() {
42 dogamesbin "hugor"
43 dodoc README
44 doicon "${FILESDIR}/hugor.png"
45 make_desktop_entry hugor Hugor "hugor" Game "GenericName=Hugo Multimedia Interpreter\nMimeType=application/x-hugo-image;"
46 insinto /usr/share/icons
47 doins -r "${FILESDIR}/hicolor"
48 insinto /usr/share/mime/packages
49 doins "${FILESDIR}/hugor.xml"
50 prepgamesdirs
53 pkg_postinst() {
54 fdo-mime_desktop_database_update
55 fdo-mime_mime_database_update