hugor: LICENSE="Hugo"
[gentoo-interactive-fiction.git] / games-engines / hugor / hugor-9999.ebuild
blob17e8477f0e96e2123b5c960f466cc5d96dc60b00
1 # Copyright 1999-2011 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
5 EAPI=3
6 EGIT_REPO_URI="git://git.assembla.com/hugor.git"
7 inherit eutils fdo-mime games qt4-r2 git-2 confutils
9 DESCRIPTION="Multimedia interpreter for Hugo text adventures"
10 HOMEPAGE="http://ifwiki.org/index.php/Hugor"
12 LICENSE="Hugo"
13 SLOT="0"
14 KEYWORDS=""
15 IUSE="fmod +sdl"
17 DEPEND="x11-libs/qt-gui:4
18 sdl? ( >=media-libs/sdl-mixer-1.2.12[mad,midi,modplug] )
19 fmod? ( media-libs/fmod )
20 x11-misc/shared-mime-info"
22 pkg_setup() {
23 confutils_require_one fmod sdl
26 src_configure() {
27 if use sdl; then
28 eqmake4 SOUND=sdl
29 else
30 eqmake4 SOUND=fmod
34 src_install() {
35 dogamesbin "hugor"
36 dodoc README
37 doicon "${FILESDIR}/hugor.png"
38 make_desktop_entry hugor Hugor "hugor" Game "GenericName=Hugo Multimedia Interpreter\nMimeType=application/x-hugo-image;"
39 insinto /usr/share/icons
40 doins -r "${FILESDIR}/hicolor"
41 insinto /usr/share/mime/packages
42 doins "${FILESDIR}/hugor.xml"
43 prepgamesdirs
46 pkg_postinst() {
47 fdo-mime_desktop_database_update
48 fdo-mime_mime_database_update